Trying to read user reviews redirects to the same page.

#1 Posted by weaveworld (12 posts) -

Well, the title says it all. The one time outside of E3 I visit here the site is bugged as hell ;p.

#2 Posted by s_h_a_d_o (1291 posts) -

Confirmed - cannot view individual reviews, and keep getting taken back to the generic listing page.

#3 Edited by Xpliode (7 posts) -

Same here. Tried accessing user reviews on the phone, tablet, and laptop. The links appear correct (different for each specific user review) but all of them simply reload the page I was already on. I don't write lots of reviews, but if people can only see the first 32 words of each, there's little point in writing another.

Edit: This forum claimed my post was "Edited" after posting my initial reply! NOW it has been edited - which was a glitchy process. Also, I just noticed there's no way to preview a game review before submitting it. What in Dalmatian has happened to this site lately? This used to be the go-to place for game reviews. Now it's awful.

#4 Edited by BorosandJerk (9 posts) -

I can say that it literally started yesterday between 1:00 pm and 6:00 pm. I was about to reread my review for Ruff Trigger because I think it's really funny and ended up redirected to the same page, then when I decided to check other reviews, I couldn't read anyone elses review either. The only one I could read were the Gamespot official reviews.

#5 Posted by Azghouls (681 posts) -

Yep - me too. Even my review Arms Forces Corp suddenly disappeared yet I can see it in my list of reviews.

http://www.gamespot.com/armed-forces-corp/reviews/?typeId=2200&id=12577062

#6 Posted by jepsen1977 (9 posts) -

Me too - can't read reviews and that's one of the main reasons to be here so....

#7 Posted by Cloud_imperium (2571 posts) -

When this buggy website will finally be fixed .?

#8 Posted by KiIIaKnight (183 posts) -

Having the same problem. Would like to be able to read inFamous: Second Son reviews, but can't (including my own).

#9 Edited by Mikey2K10 (114 posts) -

I'm having the same problem. Wanted to read some of my user reviews, but keeps redirecting me to the main listing of reviews for a particular game. Annoying as hell.

#10 Edited by BrandonNocaute (4 posts) -

Same here :(

#11 Posted by DigitalDame (3888 posts) -

Yikes, sorry about that guys. Reported!

#12 Posted by Azghouls (681 posts) -
#13 Posted by KiIIaKnight (183 posts) -

@DigitalDame: Yes, thank you. Just as an FYI, still occurring as of 3pm CST on Thurs Mar. 27th. Have tried the obvious things like clearing history, cache, etc. and trying another browser, logging out, logging back in, etc

#14 Posted by DrDobalina (44 posts) -

This has been broken for weeks for me. Why did they have to change this site to make it much slower, and break everything?!

#15 Posted by GAME-QUEST-EX (196 posts) -

Also confirmed: I'm experiencing the same problems. Whenever I try to re-read any of my uploaded reviews, or read the reviews of other gamers on the site users, I get re-directed back to the main page for the game in question.

Anyone know when this problem will be fixed?

#16 Posted by thorn3000 (216 posts) -

yep joining the queue, it is not possible to view either reviews or ratings, so it is also not possible to edit or delete any of them

#17 Edited by GreySeal9 (24114 posts) -

WTF? Why in the world is it taking so long for you guys to fix this?

#18 Posted by GattsTaichou (48 posts) -

I can't even read my OWN review. WHAT THE HELL? When are we going to revert to the original Gamespot that worked so well for years? Why did we have to change to this terrible visual labyrinth of nonsense?

#19 Posted by Azghouls (681 posts) -

Do we have a time frame on this as it's still not fixed.

#20 Posted by stylyy (143 posts) -

This should be resolved now.

#21 Posted by Azghouls (681 posts) -

@stylyy: Thanks - it's actually better as when I click on the main title name, it goes directly to the user review. Thanks again :)

#22 Posted by s_h_a_d_o (1291 posts) -
#23 Posted by Azghouls (681 posts) -

Sadly it broke again...

http://www.gamespot.com/operation-thunderstorm/reviews/?typeId=2200&id=12570743

Just click on my review (it's the only one) and it redirects you back therefore cannot read the review.

#24 Posted by Gelugon_baat (19389 posts) -
#25 Posted by Cloud_imperium (2571 posts) -

@stylyy: It is broken , once again .

#26 Edited by Gelugon_baat (19389 posts) -