Another PS4 controller question.

Avatar image for the_bi99man
#1 Posted by the_bi99man (11256 posts) -

So i got a bluetooth adapter, an ASUS USB-BT400. Still can't get the PS4 controller to work. I installed the drivers for the bluetooth adapter, now I have a bluetooth icon in the system tray. I put the controller in pairing mode, it showed up in the devices list on the PC, I paired them, but it won't work any further. I turn on the controller, a notification pops up saying a bluetooth device is trying to connect. I click to "allow" it, it says the drivers installed properly, then the controller shuts off. Over and over again. What am I missing? Do I need DS4? I only intend to use it with Steam, and it works perfectly already using the Steam Link, I just want to be able to use it directly on the PC without going through the Link.

Avatar image for WESTBLADE
#2 Posted by WESTBLADE (416 posts) -

@the_bi99man:

Hmm, works perfectly for me with that dongle (i also got an X1S controller connected through it). Paired natively for me. Try to reset the pairing; remove the device from bluetooth pairing, click the the reset button on the back of the DS4, hold Share+PS buttons and try it again. It should be just plain white glowing, shown as ''Wireless Controller'' in devices and work as a standard DINPUT device.

Maybe you should check the latest DS4Windows utility: https://ryochan7.github.io/ds4windows-site/. Personally, i had no issues at all with that utility - works flawlessly for me. You can use it either as a standard DINPUT (native) device or fully modify the input (XINPUT+KB/M) to your liking. Be sure to grab the latest version (1.5.19 as of now).

BTW, is your PS4 controller genuine Sony DS4 gamepad?

Avatar image for the_bi99man
#3 Posted by the_bi99man (11256 posts) -

Thanks a bunch. I just reinstalled the drivers and re-paired it and it seems to be working now. And yeah, it's a genuine Sony DS4. Thanks again.

Avatar image for WESTBLADE
#4 Posted by WESTBLADE (416 posts) -
@the_bi99man said:

Thanks a bunch. I just reinstalled the drivers and re-paired it and it seems to be working now. And yeah, it's a genuine Sony DS4. Thanks again.

Glad to hear that...👍