Why am I getting spammed by Gamespot?

This topic is locked from further discussion.

#1 Posted by SnakeEyesX80 (2134 posts) -

Not sure how this happened, but two news articles that I posted a single comment in is now updating me with emails every single time some posts a comment. Uh, not sure what to do now. Help.

#2 Posted by harry_james_pot (11160 posts) -

Go to your profile > Settings. Scroll down to the end, and you'll find the email notification settings.

Also in comment sections, right below the comment box there's a "follow" button. I'm not sure what it does, but maybe that's it and you clicked on it by mistake.

#3 Edited by SnakeEyesX80 (2134 posts) -

@harry_james_pot: Crazy thing is that I've already disabled and unchecked those options in settings. I'm still getting emails after those have been turned off. I don't see an option where I would've checked to follow the news article. It's just weird because I didn't have this problem before.

#4 Edited by DigiRave (8 posts) -

@harry_james_pot: Yeah, GS doesn't have a "Notify me of replies to my comment, but don't notify me when everyone else posts" option. This is something GS needs to fix. I DO want to receive notifications, just not from people that have nothing to do with my comment, the comment I am replying to, or any of the comments in that chain.

#5 Posted by foxrock66 (403 posts) -

You ain't alone. Lots of peeps having this issue and it seems to be getting worse.








I guess they're working on it?

I really don't know. What I've had to do for the time being is unsubscribe from any conversations I was in and have mostly stopped commenting. If you comment again, you'll get emails from wherever you commented until unsubscribe again. Yes, this means unsubscribing every time you comment, or just don't comment until this is resolved :/

#6 Edited by leon2365 (13087 posts) -

its a bug that is (hopefully) being fixed.