This topic is locked from further discussion.

Avatar image for cakeorrdeath
cakeorrdeath

19079

Forum Posts

0

Wiki Points

0

Followers

Reviews: 5

User Lists: 0

#1 cakeorrdeath
Member since 2006 • 19079 Posts
I keep getting text being replaced by "forbidden> even though I am not using censored words.

Normal words like s.t.y.l.e are being replaced.
Avatar image for Ponsardin
Ponsardin

4500

Forum Posts

0

Wiki Points

0

Followers

Reviews: 1

User Lists: 0

#3 Ponsardin
Member since 2006 • 4500 Posts
It happened to me few times today and it was really frustrating.
Avatar image for ulillillia
ulillillia

685

Forum Posts

0

Wiki Points

0

Followers

Reviews: 10

User Lists: 0

#4 ulillillia
Member since 2006 • 685 Posts
Because an equal sign is required immediately after the word, rather than just filter by the word itself, filter by the word followed directly by the equal sign. If a space is after the word and the equal sign, it otherwise wouldn't work as it's invalid HTML (as far as I know). If the key word was "test" for example, you'd filter the word "test=" instead and not "test" as it is.

And why is "s.t.y.l.e" forbidden? Elements within a span tag could use the "s.t.y.l.e" attribute to set the font color and font size values (or even the font face itself). I would think that at least setting colors or changing the font should be permitted, but nothing else, as long as the span's tag is closed.

Edit: Even surrounded in quotes, it would get replaced and the annoying thing is that all text after it is destroyed which is extremely annoying (thankfully I backup everything in Notepad so I just repaste what I copied to get what I had back again). I editted my post to get it back again and make changes to bypass this since "s.t.y.l.e" is not a bad word.

Edit #2: I editted my post and now I got odd spacing. Man is the text edittor seriously flawed in it's design. The code for it should almost just be rewritten, particularly the scanning part upon submission.

Edit #3: Yeah, now even more spaces are added. I once editted my post and somehow managed to undo the spacing. Weird. It appears normal in the text edittor, but not the post itself.

Edit #4:  Also, I encounter this with the smileys as well.  When I have the resolution of 1024x768 enclosed in parentheses, the 8 and the end parenthesis are converted into a smiley 8) when it's not supposed to be.  An example of this is this:  "There are many resolutions avaiable (a common resolution is 1024x768) and it's only the monitor that limits the ones available."  The eight and the ending parenthesis have been converted into a smiley which shouldn't have happened.  A smiley should only be converted if there's a space on the left side and a space or stop punctuation on the right (periods, exclamation points, or question marks).
Avatar image for cakeorrdeath
cakeorrdeath

19079

Forum Posts

0

Wiki Points

0

Followers

Reviews: 5

User Lists: 0

#5 cakeorrdeath
Member since 2006 • 19079 Posts

Edit #4: Also, I encounter this with the smileys as well. When I have the resolution of 1024x768 enclosed in parentheses, the 8 and the end parenthesis are converted into a smiley 8) when it's not supposed to be. An example of this is this: "There are many resolutions avaiable (a common resolution is 1024x768) and it's only the monitor that limits the ones available." The eight and the ending parenthesis have been converted into a smiley which shouldn't have happened. A smiley should only be converted if there's a space on the left side and a space or stop punctuation on the right (periods, exclamation points, or question marks).
ulillillia


Yeah that really annoys me too.
Avatar image for reyad-u
reyad-u

6960

Forum Posts

0

Wiki Points

0

Followers

Reviews: 3

User Lists: 0

#6 reyad-u
Member since 2006 • 6960 Posts
[QUOTE="ulillillia"]
Edit #4: Also, I encounter this with the smileys as well. When I have the resolution of 1024x768 enclosed in parentheses, the 8 and the end parenthesis are converted into a smiley 8) when it's not supposed to be. An example of this is this: "There are many resolutions avaiable (a common resolution is 1024x768) and it's only the monitor that limits the ones available." The eight and the ending parenthesis have been converted into a smiley which shouldn't have happened. A smiley should only be converted if there's a space on the left side and a space or stop punctuation on the right (periods, exclamation points, or question marks).
cakeorrdeath


Yeah that really annoys me too.

that can be fixed by putting a space between the 8 and the ) 8) = 8 )
Avatar image for ulillillia
ulillillia

685

Forum Posts

0

Wiki Points

0

Followers

Reviews: 10

User Lists: 0

#7 ulillillia
Member since 2006 • 685 Posts
Gramatically, there is no space between the 8 and the right parenthesis and other forums I visit don't do this anywhere nearly as bad as Gamespot's text edittor does.  Now being the weekend, you'll have another 2 days of dealing with the annoying forbidden errors and things.
Avatar image for Banjo4321
Banjo4321

6229

Forum Posts

0

Wiki Points

0

Followers

Reviews: 1

User Lists: 0

#8 Banjo4321
Member since 2003 • 6229 Posts
I keep trying to change my Union Short Description, but one of my links contains the word "classic" in it, and it is changing the entire HTML tag to Forbidden, preventing me from changing anything.
Avatar image for pikaby
pikaby

12720

Forum Posts

0

Wiki Points

0

Followers

Reviews: 3

User Lists: 0

#10 pikaby
Member since 2006 • 12720 Posts

I keep trying to change my Union Short Description, but one of my links contains the word "classic" in it, and it is changing the entire HTML tag to Forbidden, preventing me from changing anything.Banjo4321

Happened to me too, the #^%$^$&%$ing glitch

Avatar image for Ausguy
Ausguy

1003

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#11 Ausguy
Member since 2007 • 1003 Posts
I am having the same problem also. What a PITA this is!
Avatar image for robotopbuddy
RobotOpBuddy

65503

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: -3

#12 RobotOpBuddy  Moderator
Member since 2004 • 65503 Posts
yer this has become rather annoying...thankfully it doesn't forget the majority of posts but it has effected several large posts and it's getting very annoying...it's just specific tag attributes it seems but they're rather common words as well so it still gets in the way...the main one i've noticed it with is class, as well as any variation of the word despite it only being correct html if the word is exact....hopefully the admins will fix it soon...as it really should only filter out those words when they're inside a html tag
Avatar image for SulphuricSoul
SulphuricSoul

3937

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#13 SulphuricSoul
Member since 2005 • 3937 Posts
This is very annoying. I get a forbidden error or some other error, when I try to edit my posts, or link things, or just change my formatting which gets messed up very often...This problem gets worse when using the WYSIWYG editor, which i can't switch off now :x...i get "Your HTML is not well-formed - please check for unmatched quotes and tags"
Avatar image for ulillillia
ulillillia

685

Forum Posts

0

Wiki Points

0

Followers

Reviews: 10

User Lists: 0

#14 ulillillia
Member since 2006 • 685 Posts
Any word on this yet?  It's both c.l.a.s.s and s.t.y.l.e that are causing this problem.  If you don't want these attributes to be used (and what's wrong with s.t.y.l.e anyway for only changing font colors or the font face?), filter it not by the word itself, but with an equal sign immediately following (maybe with some spaces if HTML allows for extra spaces).  That is, filter by the string s.t.y.l.e.= instead of just s.t.y.l.e, and the same goes for c.l.a.s.s as well.  A similar thing occurs with smiley's where 8.) is converted even though it may be enclosed by other text.  To use a smiley, an extra space must precede the smiley.  That is, filter by " .8.)" instead of just "8.)" and, of course, without the periods.  These tend to get very annoying as it not only deletes everything after the case where the word is used, either forcing users to retype what they said (just to get it blanked out again), or, for those who use the trick, pasting what they had originally).
Avatar image for wickerman2004
wickerman2004

3878

Forum Posts

0

Wiki Points

0

Followers

Reviews: 13

User Lists: 0

#15 wickerman2004
Member since 2004 • 3878 Posts

Still not fixed. Can we have an update GameSpot????

Avatar image for scotty992
scotty992

2388

Forum Posts

0

Wiki Points

0

Followers

Reviews: 2

User Lists: 0

#16 scotty992
Member since 2005 • 2388 Posts

Still not fixed.

Bump.

Avatar image for phantomtech85
phantomtech85

6686

Forum Posts

0

Wiki Points

0

Followers

Reviews: 6

User Lists: 0

#17 phantomtech85
Member since 2004 • 6686 Posts
I'm having this same problem as well, and it keeps erasing some of my blog paragraphs that I worked so hard to type. Truly annoying indeed.
Avatar image for ulillillia
ulillillia

685

Forum Posts

0

Wiki Points

0

Followers

Reviews: 10

User Lists: 0

#18 ulillillia
Member since 2006 • 685 Posts
Until this is even fixed or being looked into, I strongly suggest copying your message, before clicking the submit button, into Notepad. If it happens after submitting it, just edit your message, select the entire thing, and paste what you copied in - it takes but a few seconds to get your original message back, no matter how much is lost (whether the last few words or almost the entire message) and make the fixes. Still, this forbidden thing is extremely annoying.

Edit:  The only way your message would end up being lost is if the power went out or your computer hard froze, but, even if the browser crashed, you still have it in Notepad.  This is useful, not only for temporary resolving the mayhem this bug poses, but any website with forms to fill out.
Avatar image for daqua_99
daqua_99

11170

Forum Posts

0

Wiki Points

0

Followers

Reviews: 14

User Lists: 0

#19 daqua_99
Member since 2005 • 11170 Posts
Yeh, this bug is on my nerves. Two times I've written a very long blog, and it just gets the first two paragraphs then a forbidden>. And what was the word which is wanted to block?? It was 'and'. 
Avatar image for Gallion-Beast
Gallion-Beast

35803

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#20 Gallion-Beast
Member since 2005 • 35803 Posts
This error just deleted about 20 lines of text in a long post l had written.........
Avatar image for Lambo2468
Lambo2468

12245

Forum Posts

0

Wiki Points

0

Followers

Reviews: 2

User Lists: 0

#21 Lambo2468
Member since 2006 • 12245 Posts
gamespot this is very annoying please fix it
Avatar image for blazealot420
blazealot420

1655

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#22 blazealot420
Member since 2004 • 1655 Posts
Glad to see it wasn't just me having this problem, doesn't seem to of been fixed yet.
Avatar image for Davidhye
Davidhye

12018

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#23 Davidhye
Member since 2005 • 12018 Posts
i hate that error too. it's very annoying if you wrote a lot -and then most of it erased :(
Avatar image for Banjo4321
Banjo4321

6229

Forum Posts

0

Wiki Points

0

Followers

Reviews: 1

User Lists: 0

#24 Banjo4321
Member since 2003 • 6229 Posts
GameSpot, please fix this. This is a major problem that is affecting many people. My union has the word 'classic' in the title, so links to my union and sig banners are being blocked.
Avatar image for jekyll
jekyll

9140

Forum Posts

0

Wiki Points

0

Followers

Reviews: 145

User Lists: 0

#25 jekyll
Member since 2002 • 9140 Posts
It's not just GameSpot; it's Tv.com, too, and I'm guessing all the CNET Entertainment sites. And it needs fixing now.
Avatar image for scotty992
scotty992

2388

Forum Posts

0

Wiki Points

0

Followers

Reviews: 2

User Lists: 0

#26 scotty992
Member since 2005 • 2388 Posts
FIX IT NOW!
Avatar image for drbob
drbob

253

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#27 drbob
Member since 2002 • 253 Posts
This is atrocious and totally unacceptable. It's made worse by the fact that the whole post after the banned word is lost. I was tring to post a link that had the word class embedded within it - my 30 line post was decimated.

All well and good to say copy your work to notepad, but it's easy to forget and the bug is likely to catch out a lot of people who aren't yet aware of it..
Avatar image for Banjo4321
Banjo4321

6229

Forum Posts

0

Wiki Points

0

Followers

Reviews: 1

User Lists: 0

#28 Banjo4321
Member since 2003 • 6229 Posts
http://unions.gamespot.com/classicadventur

The link above is for my union.  I can't even make it clickable or I'll get the forbidden error.
Avatar image for Viennoiserie
Viennoiserie

2205

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#29 Viennoiserie
Member since 2007 • 2205 Posts
I've just realised that 'classic' is censored because it contains 'class'. Same thing goes to derivates like 'classes'.
Avatar image for digi_matrix
digi_matrix

6600

Forum Posts

0

Wiki Points

0

Followers

Reviews: 12

User Lists: 0

#30 digi_matrix
Member since 2004 • 6600 Posts
Same thing happened to me, I was writing this huge blog post and wanted to only "preview" and it removed 40 LINES OF TEXT! :evil: How come so many bugs lately one by one appearing on the site? Is it a virus epidemic rampant on the gamespot servers?
Avatar image for bofe1234
bofe1234

3046

Forum Posts

0

Wiki Points

0

Followers

Reviews: 10

User Lists: 0

#31 bofe1234
Member since 2005 • 3046 Posts
half of my SMG STICKIED thread was wiped from this god awful error. is there any way to fix it. i have it all copied but how do i fix it. if i have to erase some hyper links i will just as long as the threads major info isnt jeopardized
Avatar image for drbob
drbob

253

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#32 drbob
Member since 2002 • 253 Posts
half of my SMG STICKIED thread was wiped from this god awful error. is there any way to fix it. i have it all copied but how do i fix it. if i have to erase some hyper links i will just as long as the threads major info isnt jeopardizedbofe1234

The bug will cause any banned word within a hyperlink to be replaced with "forbidden>". The rest of the post will be truncated. If you want to preserve your links you can work around the problem by using the tinyurl service to create an address that doesn't include the banned word.
Avatar image for robotopbuddy
RobotOpBuddy

65503

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: -3

#33 RobotOpBuddy  Moderator
Member since 2004 • 65503 Posts
I've just realised that 'classic' is censored because it contains 'class'. Same thing goes to derivates like 'classes'. Viennoiserie
yup..as i've already mentioned it's just deleting words that are normally blocked when they're in the html, whether they're in the html or not..i've also noticed that if there's no formatting at all in the entire block of text it'll sometimes let you post those words...like this: class style but if i add in formatting, for instance something like increasing the text size, then it'll block it out; it used to do it for things in bold and other things as well but it seems as tho it's not blocking them out now...style class
Avatar image for fantasyfacade
fantasyfacade

8317

Forum Posts

0

Wiki Points

0

Followers

Reviews: 6

User Lists: 0

#34 fantasyfacade
Member since 2006 • 8317 Posts
I used to have the same problem, but I figured out how to get around it. Its not due to banned words its due to html. It seems to be related to the type of html tags used. Firefox will use one and explorer will use another you have to use paragraph tags instead of break ones.
Avatar image for scotty992
scotty992

2388

Forum Posts

0

Wiki Points

0

Followers

Reviews: 2

User Lists: 0

#35 scotty992
Member since 2005 • 2388 Posts

Are they working on this? anyone know when it will be fixed?

Avatar image for VinceL
VinceL

3856

Forum Posts

0

Wiki Points

0

Followers

Reviews: 1

User Lists: 0

#36 VinceL
Member since 2004 • 3856 Posts
q_oats is working on this - a bug report has already been assigned to him. Not sure when it will be fixed.
Avatar image for scotty992
scotty992

2388

Forum Posts

0

Wiki Points

0

Followers

Reviews: 2

User Lists: 0

#37 scotty992
Member since 2005 • 2388 Posts
Ah cool.
Avatar image for facit_90
facit_90

840

Forum Posts

0

Wiki Points

0

Followers

Reviews: 6

User Lists: 0

#38 facit_90
Member since 2005 • 840 Posts
That error is really annoying.
Avatar image for Draqq_Zyxorian
Draqq_Zyxorian

3952

Forum Posts

0

Wiki Points

0

Followers

Reviews: 23

User Lists: 0

#39 Draqq_Zyxorian
Member since 2004 • 3952 Posts
I hope this gets first priority. It's difficult posting large issues of ReviewSpotting and having to destory the integrity of user reviews by altering words like class= and style=, etc. There wasn't a glitch like this before so I'm certain that it can be fixed.
Avatar image for Teivan
Teivan

1967

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#40 Teivan
Member since 2005 • 1967 Posts
They're attributes for various HTML tags that presumably aren't allowed. (href, for example, is an attribute of the Anchor tag, used for hyperlinking, but that one's allowed). Class and style are both apparently not allowed and getting removed from the HTML in a rather sloppy manner, so it manages to remove it from plain text, not just HTML. Best bet is to wait for the admins to fix it.EJ902

Sloppy isn't the word I would have used, but yes, this is exactly what is happening. We are probably overly strict on what we allow, but then again we don't have problems like the mySpace viruses. Unfortunately, there is no easy way to both allow the freedom of html why protecting against javascript exploits. Words like class and style will unfortunately be filtered out for a while as we try to come up with a better method. We are erroring on the side of caution.

Also, fyi, as some people have expressed possible solutions like checking for style= instead of style, there are ways around that by stupid browser bugs letting something like style"= or style/= actually work. Heck, imo, if the browsers themselves can't always get it right, how can we? :P The reason why style and class are restricted in the first place is because they are a doorway into several js exploits.

Oh, and if you're wondering how I got those words into my post, well, I'm a dev and I can just edit the db. I normally don't do that, but I wanted to be clear in my posting. I hope this helps everyone understand a little more.