Steam app not running (already running)

This topic is locked from further discussion.

#1 Posted by darkspineslayer (19766 posts) -

 

This is a big reason why me and PC gaming don't get along. So much random bullshit.

Anyone have any idea how to fix this? I try loading once, it dosn't load and from then on until I force quit steam I get that error.

Running on an iMac. 

#2 Posted by SerOlmy (1714 posts) -
First Mac =/= PC gaming. Second, find whatever the task manager equivalent on Mac is and shut down the process for whatever game you are trying to run. If that doesn't work then delete the local content and redownload it. If that doesn't work, google is your friend.
#3 Posted by darkspineslayer (19766 posts) -
[QUOTE="SerOlmy"]First Mac =/= PC gaming. Second, find whatever the task manager equivalent on Mac is and shut down the process for whatever game you are trying to run. If that doesn't work then delete the local content and redownload it. If that doesn't work, google is your friend.

Funnily enough, the board title is "PC and Mac gaming", bro. Get over yourself, it's unfortunately the best thing I have to play PC games. And I know how to use google. I obviously wouldn't be here if it helped, derp.
#4 Posted by ArisShadows (22645 posts) -

The program or game is running the background.

You need to close it.

#5 Posted by ArisShadows (22645 posts) -
Cmd+Opt+Esc
#6 Posted by darkspineslayer (19766 posts) -

The program or game is running the background.

You need to close it.

ArisShadows

I've tried locating and closing the process via activity monitor. Just puts me back at square one.

game dosn't even show up under the force quit window.

#7 Posted by Sweetbackhair (1926 posts) -
I already replied to you in SW, but maybe try restarting your PC.
#8 Posted by xsubtownerx (10705 posts) -
What game are you playing? This has happened to me a lot of times with Heroes of Might and Magic VI. Stupid uplay and steam weren't working well together (and probably still don't).
#9 Posted by slabber44 (985 posts) -
I've come across that error a few times with different games and usually there's some kind of glitch with Steam and you need to exit Steam altogether and then sign back in again. Yes it's a pain, but it happens very rarely to me at least. In your picture it seemed like you were downloading or updating a game which might have caused the glitch when trying to start the game.