Smite launcher won't launch smite.

This topic is locked from further discussion.

#1 Posted by Superlogo12 (14 posts) -
Ok so i was playing a game for smite then after the victory i exited the game then after a while i opened smite and then a messaged came saying dx9 error something.Then i decided to repair fix it in diagnostics while the scan was in midway i exited it and restarted my laptop.Then when i launched the launcher it said **Validating** so i waited for it it.After a while the play button still didn't light up i clicked it nothing so i did another repair/validating after %100 complete it still said **Validating** so it won't let me get into the game any one got any fixes?.I can't reinstall the game at the moment because i am at someone house for a week and there internet is just 10GB.I have posted a thread about this on smite forums but there hasn't been any answers for 2 days.
#2 Posted by Sword-Demon (6970 posts) -
is this through steam? after it hits 100% and still says it's validating, just leave it for an hour or 2
#3 Posted by Superlogo12 (14 posts) -
No it is not through steam and i downloaded it directly from there website i will let it run for an hour then tell you the results.
#4 Posted by Superlogo12 (14 posts) -
[QUOTE="Sword-Demon"]is this through steam? after it hits 100% and still says it's validating, just leave it for an hour or 2

Left it running for almost 4 hours but still **Running Validation** what is up with the game i want to play it so badlyyyyy...
#5 Posted by Superlogo12 (14 posts) -
Opps putted 4 in instead of 3 i left it running for almost 3 hours.
#6 Posted by Superlogo12 (14 posts) -
Ok so i went on manager account then to the games tab and under smite tab it said "Status:Unregistered,Player Name:".So there is no player name and my status says unregistered.So when i go over it in a highlighted text it says"Registration is Free!Register on our homepage to begin playing".So i don't understand where am i meant to register when my account has already been created.