What has happened to Youtube?.

This topic is locked from further discussion.

#1 Posted by skipper847 (3333 posts) -

What has happened to youtube. You can not watch in window mode any more as the text is all blurred out on the videos. Brakes nearly every 5 minutes and slow loading times and the design is just messed up. I like to look at tutorials alot on how to install mods other things and like that and in the description they put links up to the web site. The links are there but then all of a sudden they are no where to be seen. Its slower to load things up and also just pauses when wants to. Any one else having problems or is it just me and if it is every one else i hope they fix it soon.

#2 Edited by lamprey263 (24135 posts) -

both Google and YouTube have been giving me tons of trouble recently, Google searches won't go anywhere, YouTube won't load, and when it does it's slow, then it just works, then it's back to slow again; don't know what's wrong, maybe it's my computer but maybe not

try clearing the browser cache I hear that sometimes helps

#3 Posted by -ParaNormaN- (834 posts) -

@lamprey263 said:

both Google and YouTube have been giving me tons of trouble recently, Google searches won't go anywhere, YouTube won't load, and when it does it's slow, then it just works, then it's back to slow again; don't know what's wrong, maybe it's my computer but maybe not

try clearing the browser cache I hear that sometimes helps

I've been experiencing that too. Annoying as hell.

#4 Edited by Floppy_Jim (25759 posts) -

Youtube commited suicide for me a couple of days ago. Most videos are a plain black screen with nothing happening at all.

#5 Posted by HuggyBear1020 (456 posts) -

Haven't had any of these problems.

#6 Posted by GreySeal9 (24413 posts) -

@Floppy_Jim said:

Youtube commited suicide for me a couple of days ago. Most videos are a plain black screen with nothing happening at all.

Why didn't you get YouTube the help it needed?

#7 Posted by Shottayouth13- (6806 posts) -

I'm having massive trouble even playing a youtube video without it buffering every minute. Every other site I go on, videos load fine and smoothly, but on Youtube? Nope.