omnimodis78's forum posts

Avatar image for omnimodis78
#1 Posted by omnimodis78 (46 posts) -

For sure it was a fuse! I had the same thing happen to my Logitech Z-5500 but fortunatelly it was still under warranty and I actually got a replacement system (I actually ordered the replacement fuse but they all kept popping so Logitech decided to just replace the whole system). Sorry about your luck, such things happen it just sucks when it's you... :(

Avatar image for omnimodis78
#2 Posted by omnimodis78 (46 posts) -

It's hard to narrow down any such issues by reading your post - try to summarize a little bit and make things shorter, and I assure you that more people will respond. That said, I have a few questions (and please don't get offended, I know these are basic, but I know from experience that sometimes it's good to look at things from a basic point of view):

1. When you power on your controller, does it light up? If so, when you press the 3D matrix button, does the green light come on for that also?

2. The popping sound, did it come from the speakers or did you hear a pop coming from your computer case?

3. When you turn on the speakers, do you hear a very quiet (normal) pop sound from the subwoofer? Put your ear right there and check?

4. Are you 100% sure that everything is connected correctly? If in doubt, disconnect everything and do it again.

5. Please clarify if you're using a soundcard or onboard sound. Does windows recognize an audio device? Is it installed correctly?


I look forward to your reply!

Avatar image for omnimodis78
#3 Posted by omnimodis78 (46 posts) -

No real point in making any further comments, but like everyone already stated, yes it will play it, but only on low settings (including low resolution). Why not go with sometime a little higher? If you're low on cash, just look up a used 8800 on your local kijiji (I don't work for them btw). I wouldn't waste my money on anything less than an 8800GT ! Good luck!

Avatar image for omnimodis78
#4 Posted by omnimodis78 (46 posts) -
Your system is decent - and it will play nearly all the games, albeit not on the highest settings (for most). It may have already been asked (I scanned through most of the responses thus far) but what size is your screen?
Avatar image for omnimodis78
#5 Posted by omnimodis78 (46 posts) -

LG - 47" ****/ 1080p / 120Hz / LCD HDTV

Samsung - 50" ****/ 720p / 600Hz / Plasma HDTV

which is better

alphaqup03
600Hz is a total joke! Even 240Hz is still a little too much and there are noticeable "issues" with the video quality (if you don't believe this just go to your local Bestbuy and check out a demo), 60Hz is good, but I admit that 120Hz is amazing!
Avatar image for omnimodis78
#6 Posted by omnimodis78 (46 posts) -
You would need a better PSU - nothing less than 500W just to be safe - and these days you can get a 650W at fairly reasonable prices. Good luck!