Game-breaking bug at Ascension

Avatar image for Varg669


Forum Posts


Wiki Points



Reviews: 0

User Lists: 0

#1 Varg669
Member since 2010 • 25 Posts

So I came across a game-breaking bug where I can't continue on. It's on the Ascension of Atlas level. When you get to Atlas' chain and you're supposed to climb walls with falling rocks there's a bug at the very end.

When I get to the chain and I break it, the game encounters a bug where instead of showing me the cinematic it just turns to black and the music keeps looping. I can still control Kratos and hear him moving around as well as pausing the game. I've tried reloading the checkpoint and doing it again as well as returning to the last save point and doing it again. It still encounters the same problem.

I've taken out the disc and cleaned it, there's hardly any scratches on it and I've tried restarting the system etc. Nothing seems to work, I've read only one other thread on this and it said the bug is due to you sliding down the wall to long (Holding down R1) but I've gotten through the wall part with sliding down at all and it still occurs. However that problem was on the HD Collection and I'm playing the original PS2 game.

If anyone has any info about bypassing this bug I'd be grateful.

Here's a screenshot of where the bug occurs: