Xbox 360 Ethernet Problem

This topic is locked from further discussion.

Avatar image for Abctrakt
#1 Posted by Abctrakt (25 posts) -

Okay, so I've been playing Xbox 360 for a few months now, and when I got LIVE I found out that you could simply plug up an ethernet cord to it and it'll connect me to my router, and ONWARD TO ONLINE PLAY. It WORKED I had PERFECT connection PERFECT SPEED NO LAG- It was GREAT....However it decided to STOP working randomly after a while. I've been trying my best to find ALL WAYS of connecting. I REALLY don't wanna go out and buy a stupid wireless adapter, cause A. $$$$, and B. I'm pretty sure that 100Mps is faster than 40 or whatever. So I got on to Xbox.com to diagnose the problem, no help. I Called XBOX people, and after HOURS of "What?" and "I ALREADY DID THAT!" I gave up with those dumbass Indian bastards. They sent me a return box to diagnose the issue, but with GTAIV coming out so soon I thought MAYBE NOT. I was recently talking to friend about it and he seemed to think that because it happened close to a time that there was a storm, that maybe the ethernet port got struck by lightning...NOT COVERED BY WARRANTY OF COURSE. Is there ANY WAY to either replace the current ethernet port just like adding one to a PC, or does anyone have any thoughts? HEEEELLLLPPP!

Avatar image for Abctrakt
#2 Posted by Abctrakt (25 posts) -
I hate to bump. But I need help lol
Avatar image for A22A221N_47
#3 Posted by A22A221N_47 (770 posts) -
if you bought it at best buy then you could replace it other then that idk
Avatar image for Abctrakt
#4 Posted by Abctrakt (25 posts) -
any ideas
Avatar image for Abctrakt
#5 Posted by Abctrakt (25 posts) -
Nope traded in all my stuff at EB Games to get it lol. Anything else?
Avatar image for A22A221N_47
#6 Posted by A22A221N_47 (770 posts) -
tell EB games that it broke the first day you used it and bring them the reciet
Avatar image for chele519
#7 Posted by chele519 (25 posts) -

We had that happen at work when there was a storm and it turned out we just lost one of the ports on the router. This may sound like a stupid question but have you tested the cable direct to the xbox from the modem without going thru the router? Maybe it isn't the xbox.