Took too long to start error problem

Avatar image for danno1
Danno1

25

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#1 Danno1
Member since 2018 • 25 Posts

Ok this idiotic error is driving me crazy, I've been getting this error(0x8027025a)at least once a week for months now and I can't figure out how to make it stop or go away long term. I have tried factory resetting and power cycling numerous times, I've tried clearing persistent storage as well as deleting and redownloading my profile. In addition I have tried exchanging for a another Xbox One S and deleting and redownloading all of the games on my external hard drives.

I used to get another error 'do you own this game or app?', but I haven't gotten that error for four months now so that error seems to have gone dormant for the foreseeable future. I'm truly baffled and very frustrated by this 'took too long' error though, I don't understand wny I'm getting it on a regular basis. One year ago I almost never got this error, now its happening all the time. Why? Does anyone know how to make this stupid error stop?

Just a couple of other facts for everyone A. I'm hardwired with a good connection and reliable speeds. B. Only one profile and I don't gameshare with anyone.

Avatar image for Bond007uk
Bond007uk

935

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#2 Bond007uk
Member since 2002 • 935 Posts

Hi,

How do you have your console connected to the power? Direct to the mains or via a power strip? Any surge protection in-between.

Avatar image for danno1
Danno1

25

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#3 Danno1
Member since 2018 • 25 Posts

@Bond007uk: Ddirectly to the wall

Avatar image for amirai
amirai

4

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#4  Edited By amirai
Member since 2019 • 4 Posts

if you didn't do it the way described above then make sure to give it a try. Usually fixes it in my experience.

TutuApp

9Apps

Showbox

Avatar image for lilhurk1985187
lilhurk1985187

407

Forum Posts

0

Wiki Points

0

Followers

Reviews: 3

User Lists: 5

#5 lilhurk1985187
Member since 2014 • 407 Posts

When i had this problem it was because my 1TB external hardrive was busted and couldnt load any of my digital games installed on it. Got rid of it and the problem was solved.