Help with the plug and play kit!

This topic is locked from further discussion.

Avatar image for cementface9
#1 Posted by cementface9 (1537 posts) -

I just bought a plug and play kit for my wireless controller. The directions say that the light on the cord should glow red, and turn green when it's fully charged and ready to play wirelessly, but my light won't come on at all. It's green for almost 1/3 of a second as I plug it in. After that, it doesn't light up. I've plugged it in every USB port on my 360. I've plugged it in before and after booting up the 360. I've unplugged and plugged the cord. I'm running out of ideas. And the controller won't play without the wire, so I know it's not charged. So am I doing something wrong? What am I missing here?

Avatar image for Berserker_2
#2 Posted by Berserker_2 (5948 posts) -
Do you have the battery pack inserted into the controller?
Avatar image for BuffysFaith
#3 Posted by BuffysFaith (2007 posts) -
Did you put the rechargeable battery in? lol. Seriously though it might be defective. Cause I just plug mine into the top of the controller and put it in the usb port on the front of my 360 and it works fine with both of my controllers.
Avatar image for RMANPOWER
#4 Posted by RMANPOWER (2734 posts) -

Plug it into your controller, it will flash, then turn off. It charges while you play, but when your finish playing. Just simply turn off the power and it will turn off for a second, then it will turn red meaning it's charging.

Avatar image for cementface9
#5 Posted by cementface9 (1537 posts) -

Yes I have the battery pack inserted. I hope it's not defective. Can the security device disabler mess with it at all? Because on my way out of the store I set off the alarm. The guy at the door went nuts on the thing with that scanner doohickey.

Avatar image for Cobalt75
#6 Posted by Cobalt75 (313 posts) -
Mine did this too when I first bought it.  I thought it was defective, luckily I didn't return it.  I didn't use it for a few days and tried again.  It worked that time and ever since.  Can't explain it.  I suggest you leave it plugged in for several days and use it like a corded controler.  That's the only thing I think I did.  I also try to plug into the controller first, then the console before turning the console on.    
Avatar image for cementface9
#7 Posted by cementface9 (1537 posts) -
Will do, thanks guys.
Avatar image for Raz0redge
#8 Posted by Raz0redge (1796 posts) -
I'm assuming that the battery pack that you put in doesn't have any charge? If it's in deep discharge, it might take a little while to get going. So leave it plugged in for a while and see what happens..