360 won't read my disc

This topic is locked from further discussion.

Avatar image for Jak_Skellington
#1 Posted by Jak_Skellington (25 posts) -
It won't read the 4th disc of Lost Odyssey. It either freezes, or it tells me to clean it and restart the console. But the disc is squeeky clean. Not a scratch or blemish on it. And as far as I can tell it plays my other games fine. What should I do
Avatar image for Dawq902
#2 Posted by Dawq902 (6796 posts) -


I have a similar problem w/ my R6V2 disk, every time i put it in it tells me it is a DVD or something. I just open the tray, turn the disk to a dif position, and put it back in the 360 until it works. If that does not work check for scratches on the edge of the disk, that's what happend to my Mass Effect disk.

Avatar image for Jak_Skellington
#3 Posted by Jak_Skellington (25 posts) -
Moving the disc seemed to work for a little bit, but it still froze after the first couple cut scenes
Avatar image for Jak_Skellington
#4 Posted by Jak_Skellington (25 posts) -
What if I install it? How do you install games
Avatar image for OniSwordsman
#5 Posted by OniSwordsman (86 posts) -
I am having the same problemwith my Fable II but it just crashes my system... do you think the systems are getting picky? cause all other video games work perfectly... just the game i have beeen waiting to play for a year....
Avatar image for Jak_Skellington
#6 Posted by Jak_Skellington (25 posts) -
Crap, I can't install it either because it can't read it
Avatar image for littlelegs123
#7 Posted by littlelegs123 (25 posts) -


When i put my disc in the tray it starts reading the disc then stops and says open tray as if it hasn't got a game in and i have tryed everything i can think of at the moment, unplugged everything in my xbox and then plug it back in a few days later but nothing seems to work and i know its definitely not the disc because i have got new games. I would appreciate any help that you can offer me


Avatar image for nintendo2200
#8 Posted by nintendo2200 (373 posts) -
The 360 has a DVD kind of lens, You guys have to get the lens cleaned.
Avatar image for sergeineoshadow
#9 Posted by sergeineoshadow (682 posts) -
Wow, I am having the same problem! No matter what game I play, it won't read the disc 0.0 When I play online though it is perfectly fine...
Avatar image for Ravi_1900
#10 Posted by Ravi_1900 (977 posts) -
It could be due to many reasons but one of the reason is that your DVD drive lens is getting dirty since 360 streams always from DVD drive it get weared out do a thing clean it with a lens cleaning disc, for 4-5 mins if it works then please post again.
Avatar image for XxFreakmanxX
#11 Posted by XxFreakmanxX (81 posts) -
Well I had same problem with my 360, where I would put the disc in the tray and it would read it but then say open disc tray. So I called up Microsoft and they said it was the 360, so I sent in and they sent me a new one, and it was fixed. So in my opinion I would say your 360's are going bad. So call up Microsoft and see what they have to say.
Avatar image for dior21
#12 Posted by dior21 (25 posts) -
your disk drive might be trash you may have to buy a new 360 same happened to me but you may also be able to find someone who can repair your disk drive for you just look on craigslist
Avatar image for HardcoreEnigma
#13 Posted by HardcoreEnigma (25 posts) -
I know how you guys feel, my 360 won't read any disc at all and I've tried using a lens cleaner. Thank God mine is still on warranty, so I'm sending my in to get fixed.
Avatar image for byof_america
#14 Posted by byof_america (1863 posts) -

here's wut works for me:

1. Put in game that doesnt read

2. put in NBA Live 2009

3.turn off console

4. turn on again

5. repeat until XB360 reads NBA live 09

6.all other games will now read

P.s if you don't have NBA Live 2009 buy it so your 360 will work (btw i dont play it any more, i just use it to make my 360 work)

Avatar image for KSU-Wildcat
#15 Posted by KSU-Wildcat (859 posts) -

This happened to me this summer, and I googled it. What worked for me was opening the tray (with no game in the tray), and blowing into the system through there, very hard. Be careful not to spit. Blow very hard for like 30 seconds. They say dust get built up in there and can mess with things. It wouldn't read any of my games, but I did that and it has gone months without issue (knocks on wood).