Sony PS3 Official Bluetooth Headset..dead, just won't turn on :S ????

This topic is locked from further discussion.

Avatar image for drusman111
#1 Posted by drusman111 (25 posts) -

Hey guyz!

I've just stumbled across this forum/thread..coz I've been googlin' like crazy for my issue.. The problem is that I bought the Sony PS3 bluetooth headset yesterday and out of the box it worked great both with my cell and the ps3..then I left it in the USB cradle attached with Ps3 and left it for a full charge for 3 hours..now when I returned and picked up the headset..it just simply wont turn on..?? I put it back in the cradle, and the red charging light blinks for a few seconds then it goes off and then again..its just dead, wont turn on.. :/ I've been tryin to turn it on after every hour or so since morning but no luck yet..I've pressed n held the power button for like 30 seconds or so each time but it just wont even blink the damn green light.. I've read all the manuals, I'm not an amateur, I know how to handle gadgets like this..and I must tell you this is a genuine issuse so plzzz don't suggest "read the manual, hold the button longer, try to pair it and al"l...coz the issue is "it just wont power on!!!".. I'm desperate to see a positive response, hope there's a fix for it..though I've left it for a while, let some battery drain for like overnight, then I'll see wat happens :s takcare all, waitin for your replies..

Dr. Usman

Avatar image for Mckenna1845
#2 Posted by Mckenna1845 (4410 posts) -
i don't know what fix could work. I guess try letting the battery run dead, if you can as it won't switch on long enough, so that might take a longtime, otherwise get a replacement from the shop you bought it from.
Avatar image for drusman111
#3 Posted by drusman111 (25 posts) -

hey thnx,

I ordered it online, n surely returning is the last option after the weekend if I can't get it to work..but I'm tryin to save the postage if possible :/

anymore help ppl..??

Dr. Usman

Avatar image for v_rfranco
#4 Posted by v_rfranco (282 posts) -

hey thnx,

I ordered it online, n surely returning is the last option after the weekend if I can't get it to work..but I'm tryin to save the postage if possible :/

anymore help ppl..??

Dr. Usman

drusman111

have u try holding the power button cus it makes a sounds when it turns on and the power light (green light) blinks that how u know its on

Avatar image for jl1080
#5 Posted by jl1080 (52 posts) -
did you pair it through USB or wirelessly?
Avatar image for Nocturnal_Speed
#6 Posted by Nocturnal_Speed (1663 posts) -

Didn't read your post sorry....but try Deleting your "Bluetooth Headset Device" from the Accessory settings and try reconnecting again (did it a couple of days ago when I reformatted my system)

Avatar image for drusman111
#7 Posted by drusman111 (25 posts) -

Didn't read your post sorry....but try Deleting your "Bluetooth Headset Device" from the Accessory settings and try reconnecting again (did it a couple of days ago when I reformatted my system)

Nocturnal_Speed
Hey thanx for all these replies, but as you said here about reconnecting n repairing, the issue is not "device recognition" rather the issue is "device power failure" i.e it just won't turn on at all no matter where I plug it :S Its still powerless after I left it for overnight battery drainage..let's see..
Avatar image for drusman111
#8 Posted by drusman111 (25 posts) -
someone ???
Avatar image for theMarshell
#9 Posted by theMarshell (602 posts) -
Call sony and see what they have to say. Last time I checked they had a warrenty on there accessory's.
Avatar image for Macri
#10 Posted by Macri (1278 posts) -
you bought it yesterday, BRING IT BACK AND GET NEW ONE!!!!!
Avatar image for drusman111
#11 Posted by drusman111 (25 posts) -

Ya, I've mailed it back today to the seller..I bought it online at Play-Asia.com. I contacted them, and they said, once they receive it, they'll test it in their lab and if it couldn't be fixed then they'll gimme an option to either claim a refund or ask for a new headset..though I'm confused what to do..any ideas :S ??? (coz who knows the next one might malfunction as well and i'll have to pay the postage of sending at back yet again..coz this issue is getting too common with these headsets as I searched the forums all over google) ..

lets see..

Avatar image for ooGUNSLINGERoo
#13 Posted by ooGUNSLINGERoo (25 posts) -
I'm having the same problem wiuth my headset. Initially, it got through the chargiung process fine and gave me the steady red ring to show a full charge. When it didn't pair via USB or bluetooth scan, I left it and went to work. When I got back and tried again, the headset wouldn't power on at all. I didn't think it could lose a charge so quicky but I plugged it up anyway and it flashed the red ring about every two seconds and then after a while would stop flashing all together. No steady light though. Still no power. I left it to deplte it's charge and try again but I'd really like to know if anyone has a solution to this problem. Are they sendiong out defective headsets or is it something that I did to it? Any help would be greatly appreciated! I need to get this working!
Avatar image for Dylan111_PS3
#14 Posted by Dylan111_PS3 (25 posts) -
I just had this exact same problem. Bought yesterday worked fine and now today no turn on, only a short time of recharging and a blinking red ring and then... nothing! Im pissed. but I have to go now and call Sony and chew them a new A**hole Bye everyone!
Avatar image for SimBy
#15 Posted by SimBy (25 posts) -
Oh well that's just wonderful ;) It all looks like this is Sony's own little red ring of death (it's ironic yes). Bought it yesterday, worked great, charged it and it's as dead as .. well XBOX 360! :) Does not turn ON no matter what. Red ring still blinks for a while if I charge it. Looks like Sony just made another piece of **** that just doesn't work! :P
Avatar image for ferrari_102
#16 Posted by ferrari_102 (629 posts) -
[QUOTE="drusman111"]

Hey guyz!

I've just stumbled across this forum/thread..coz I've been googlin' like crazy for my issue.. The problem is that I bought the Sony PS3 bluetooth headset yesterday and out of the box it worked great both with my cell and the ps3..then I left it in the USB cradle attached with Ps3 and left it for a full charge for 3 hours..now when I returned and picked up the headset..it just simply wont turn on..?? I put it back in the cradle, and the red charging light blinks for a few seconds then it goes off and then again..its just dead, wont turn on.. :/ I've been tryin to turn it on after every hour or so since morning but no luck yet..I've pressed n held the power button for like 30 seconds or so each time but it just wont even blink the damn green light.. I've read all the manuals, I'm not an amateur, I know how to handle gadgets like this..and I must tell you this is a genuine issuse so plzzz don't suggest "read the manual, hold the button longer, try to pair it and al"l...coz the issue is "it just wont power on!!!".. I'm desperate to see a positive response, hope there's a fix for it..though I've left it for a while, let some battery drain for like overnight, then I'll see wat happens :s takcare all, waitin for your replies..

Dr. Usman

Bring it back to the store and get an exchange. If you don't have the reciept, call Sony.
Avatar image for coke07
#17 Posted by coke07 (27 posts) -

hi m8.y headset is fine,dont worry.just push and hold about 15sec mic (circle button) and when the power button start blinking,push and hold 5-10 sec power button.after that follow instruction in manual...cya

Avatar image for coke07
#18 Posted by coke07 (27 posts) -

hello.i have answer on y problem.just look my post. near down..cya...coke7

Avatar image for s1wel
#19 Posted by s1wel (375 posts) -
what can i say theres only one way to turn the thing on and thats not working send it back!
Avatar image for coke07
#20 Posted by coke07 (27 posts) -

did you do what i have write to you?hold 15 sec mic and when the power button start blinking then push and hold power button 5-7sec.this it work by me...sry m8,i dont know what else to do

Avatar image for nickhardy125
#21 Posted by nickhardy125 (25 posts) -
hey guys just push a tooth pick or a push pin into it then hold down power
Avatar image for wagnesium
#22 Posted by wagnesium (25 posts) -
Cal me amazed, but I had the same problem as of this morning, and what do you know, this trick worked..
Avatar image for valakivi
#23 Posted by valakivi (25 posts) -

hi m8.y headset is fine,dont worry.just push and hold about 15sec mic (circle button) and when the power button start blinking,push and hold 5-10 sec power button.after that follow instruction in manual...cya

coke07
Excellent, this works... Thanks
Avatar image for valakivi
#24 Posted by valakivi (25 posts) -

this worked but yesterday I couldnt turn it off...:s so I just left it like that, then it didnt turn on so I thought it was just a recharge thing, but when I plugged it with the cord it was full red (charged) and now I cant turn it back on, tried this fix but now it doesnt work....

:(