controller won't charge

This topic is locked from further discussion.

Avatar image for Scarletred
#1 Posted by Scarletred (3199 posts) -
okay so I tried turning on my ps3 ontroller today and it wouldn't work. So i plug it into the ps3 via usb and it won't charge. Any help? I have another one that is low and i'm tryign to charge it and it won't charge the little light just keeps blinking fast.
Avatar image for Scarletred
#2 Posted by Scarletred (3199 posts) -
bump
Avatar image for KurupSoldr
#3 Posted by KurupSoldr (4094 posts) -
maybe your ps3 usb ports are not working did you try using your PC's USB ports to check
Avatar image for Scarletred
#4 Posted by Scarletred (3199 posts) -

There's nothing wrong with the port because I can charge my heaadset all the time.

Avatar image for Vicius
#5 Posted by Vicius (337 posts) -
Easy, simple solution: buy a new controller or use it wired.
Avatar image for Darthmatt
#6 Posted by Darthmatt (8968 posts) -
Dont take this response the wrong way. just throwing this out there, but is your PS3 turned on when you recharge?
Avatar image for jimm895
#7 Posted by jimm895 (7703 posts) -
If your trying to charge the controller when the system is in standby it won't work that way. The PS3 has to be on when it's chargeing the controller. I am one of those people that never turns the PS3 off anyway and have never had a problem with chargeing the controller (unless I forget and leave it on or not recharge it when the battery is low) when this happens I will use any USB port close by to charge the controller.
Avatar image for sunburnwilly
#8 Posted by sunburnwilly (118 posts) -

Dead , done get another one .

Controler that is ...

Avatar image for LuckyLy
#9 Posted by LuckyLy (1987 posts) -
I tried charging the controller via the PC usb ports, but it wouldn't charge? ALL the number light were blinking instead of just one when it's charging on the PS3 so I assume that it didn't work or am I wrong?
Avatar image for canydhour
#10 Posted by canydhour (142 posts) -

You can charge your controller on your computer you know...

If you have a USB port, you can plug in the controller from there. I charge mine like that all the time and my controller is always charged.

Avatar image for danells
#11 Posted by danells (71 posts) -
You may have a faulty battery. I read somewhere that SONY will replace any faulty batteries or you can simply crack it open yourself and replace it. Check around the web for instructions or if you kept the instruction book that came with your PS3 there are instructions in it. Of course I could be wrong and your controller just freaked out, but I would call support and see what they can do.
Avatar image for wilko1971
#12 Posted by wilko1971 (299 posts) -
This maybe a daft question but have you pressed the PS button and is the ps3 on. I often manage to run at least one of my controllers completely flat and you get all the lights flashing when the controller is not paired with the PS3
Avatar image for mando74
#13 Posted by mando74 (25 posts) -
Something is wrong with one of my controllers. One works ok but the other one doesn't. When I tried to put the one that doesn't work on the charger it doesn't charge. The lights won't even come on. But when I put the other controller on the charger it charges just fine. Then when I push the PS button on the broken controller the lights still won't come on. What should I do?
Avatar image for faceman420
#14 Posted by faceman420 (637 posts) -

bah I've been havin the same problems with my controller. I'm going to order a new charger and new controller and figure out if its either the controller, the chord, or the ps3..and I just boughtthis ps3 a couple weeks ago.. got the slimothy.:|

Avatar image for NaughtyRag
#15 Posted by NaughtyRag (2309 posts) -

i had this happen before.. the recharge part that goes into the controller might be flimsy so it can move around a bit while it's plugged into the controller.. you have to work with it to hit the hot spot!..

or buy a new recharge cord..

Avatar image for Dan_Lero
#16 Posted by Dan_Lero (7487 posts) -

Please don't revive old threads, thanks.