Why does Mass Effect run like crap on my PC?

This topic is locked from further discussion.

Avatar image for xxchadxxchad
xxchadxxchad

199

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#1  Edited By xxchadxxchad
Member since 2008 • 199 Posts

So i just bought the mass effect trilogy on origin (3 isn't on steam, sadly) and booted up the first game. It runs absolutely horrible for a 7 year old game. Playing at 1080p I had to turn down the textures to low and turn off dynamic shadows to hit 60fps, and it always bogs down to around 40ish when i start moving or shooting. My PC is pretty high end, so could this be an issue with Origin? Specs:

i5 4670k

GTX 770 2GB

8gb g skill 1600mhz ram

Avatar image for bluesunmerc
bluesunmerc

281

Forum Posts

0

Wiki Points

0

Followers

Reviews: 1

User Lists: 5

#2  Edited By bluesunmerc
Member since 2014 • 281 Posts

It is likely that it is your specs. I know that mass effect 1 has issues on newer machines. I had an amd 6300 cpu and when you get to noveria the second half of that level every character and enemy was just a mass of black pixels. Had something to do with the amd bulldozer. But it is kind of weird that its running so bad. One thing have you updated it if I remember correctly none of the mass effects except 3 auto update so you do have to do that manually.

edit. I didn't even think about you having it for origin so you probably don't need to update. My copy is from when it first launched on the pc (no such thing as origin at the time :) )

http://masseffect.bioware.com/me1/pc/updates/

Avatar image for 04dcarraher
04dcarraher

23319

Forum Posts

0

Wiki Points

0

Followers

Reviews: 2

User Lists: 0

#3 04dcarraher
Member since 2004 • 23319 Posts

In nvidia control panel find or add mass efect and force max performance in the power management.

Avatar image for garywood69
garywood69

518

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#4 garywood69
Member since 2013 • 518 Posts

I don't have it on Origin but my PC version works fine. On a slower machine.

Avatar image for airshocker
airshocker

31700

Forum Posts

0

Wiki Points

0

Followers

Reviews: 3

User Lists: 0

#5 airshocker
Member since 2006 • 31700 Posts

I was just playing it a couple of weeks ago on my machine with no problems. I7-4790k, EVGA GTX 780 Ti, 16GBs 2133 DDR3 RAM, 1TB SSD, EVGA FTW Z97 motherboard.

Avatar image for deactivated-5920bf77daa85
deactivated-5920bf77daa85

3270

Forum Posts

0

Wiki Points

0

Followers

Reviews: 6

User Lists: 3

#6 deactivated-5920bf77daa85
Member since 2004 • 3270 Posts

I seem to recall there was a way to manually fix some things in the config file for optimization. It's been a while, but I think it was something like "hardware shadows on"

It doesn't run at a locked 60 fps on my Phenom II 965, but it runs a hell of a letter better than on the xbox 360.

Avatar image for deactivated-57d307c5efcda
deactivated-57d307c5efcda

1302

Forum Posts

0

Wiki Points

0

Followers

Reviews: 3

User Lists: 0

#7 deactivated-57d307c5efcda
Member since 2009 • 1302 Posts

It's the same for all of us. My old config of a i7 920 and a GTX 680 ran it about the same with dips to the 40's and my current config also runs about the same with a i7 3930k and 2 x GTX 980's. I'm pretty sure it's the game engine as ME2 and ME3 pretty much lock to 60fps. Once way to look at it is that even though it dips, it's not nearly as bad as the console versions. They dip into the 20's if not lower. Mainly it's the citadel for me that dips in FPS that badly. Still though, it's one of my favorite games of all time, even with it's inconsistencies. Maybe there is a fix like Cobra said, I personally never looked into it and just enjoyed the game, the 1440p res with AA and highest settings make it look very nice and smooth that I have always been forgiving of it's performance issues.

Avatar image for -wildflower-
-wildflower-

2997

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#8 -wildflower-
Member since 2003 • 2997 Posts

I think your computer might be trying to tell you to, "play a better game." Just a guess though. I'm no PC whiz kid or anything.

If it's not that you may have to check your Flux Capacitor, or something.

Avatar image for superclocked
superclocked

5864

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#10  Edited By superclocked
Member since 2009 • 5864 Posts

It's running on your CPU's integrated GPU instead of your videocard. Find the executable that the game's shortcut points to, manually add it to the nVidia control panel game list with the settings that you want, and disable Intel HD graphics in your motherboard's bios...

Avatar image for pigonsteroidz
PIGONSTEROIDZ

96

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#11 PIGONSTEROIDZ
Member since 2014 • 96 Posts

I had the same issues on a 980, its the way the game is. You'll get used to it and its still an amazing game

Avatar image for MlauTheDaft
MlauTheDaft

5189

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#12 MlauTheDaft
Member since 2011 • 5189 Posts

@04dcarraher said:

In nvidia control panel find or add mass efect and force max performance in the power management.

This. Your GPU might be downclocking itself because it's closer to sleeping than breaking a sweat.

Avatar image for superclocked
superclocked

5864

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#13 superclocked
Member since 2009 • 5864 Posts

The game is running on his Intel embedded HD 4000...

Avatar image for kraken2109
kraken2109

13271

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#14 kraken2109
Member since 2009 • 13271 Posts

Runs flawlessly for me

Avatar image for superclocked
superclocked

5864

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#15 superclocked
Member since 2009 • 5864 Posts

@kraken2109 said:

Runs flawlessly for me

Yeah, it only runs slow on Intel systems, due to the game running on the embedded HD 3000/4000. I provided a fix for everyone a few posts above this one...

Avatar image for jun_aka_pekto
jun_aka_pekto

25254

Forum Posts

0

Wiki Points

0

Followers

Reviews: 1

User Lists: 0

#16  Edited By jun_aka_pekto
Member since 2010 • 25254 Posts

Another possibility is newer Nvidia GPUs may have weaker DX9 performance while being strong in DX11.

I noticed this with Metro: Last Light when I forced DX9 and DX10 with my GTX 560 Ti. DX9 was the slowest out of the three (DX9, DX10, DX11).

Avatar image for jun_aka_pekto
jun_aka_pekto

25254

Forum Posts

0

Wiki Points

0

Followers

Reviews: 1

User Lists: 0

#17 jun_aka_pekto
Member since 2010 • 25254 Posts

I had to go back to this because one solution I had (for my own Mass Effect install) was to disable Origin In-game.

Right click on the game icon in the Origin app

View Game Details

Under Actions, click on Game Properties

Check the box for "Disable Origin in Game for this game." then OK

You can only use local save games. But, oh well. It's a single-player game.

Locked at 60fps.

With Origin in Game enabled, my framerates were in the teens at this spot.

Avatar image for tukker
Tukker

1

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#18  Edited By Tukker
Member since 2019 • 1 Posts

@jun_aka_pekto: You are a saint and a scholar. I have an utter beast of a PC and was so confused why my FPS would drop in certain areas and you solved it.

Thanks bud

Avatar image for danielo_the_tomato
danielo_the_tomato

1

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#19 danielo_the_tomato
Member since 2020 • 1 Posts

@jun_aka_pekto man i love you!!! I tried everything from the lowest graphics settings to force max settings in nvidia control panel and only your advice works! I was gonna uninstall the game a get a refund cause i just cant play it on 15 fps with 1050 ti so THANK YOU!

Avatar image for Byshop
Byshop

19703

Forum Posts

0

Wiki Points

0

Followers

Reviews: 11

User Lists: 0

#20 Byshop  Moderator
Member since 2002 • 19703 Posts

@danielo_the_tomato: Glad that fixed your problem, but this is a necro bump so I'm locking the thread.