USB mouse causes long boot

This topic is locked from further discussion.

Avatar image for Zopple
#1 Posted by Zopple (31 posts) -

Hey, if I have my USB mouse plugged in on start-up, the bios splash stays for 20 seconds or so, if I restart with it unplugged it's visible for less than 2 seconds. I can start-up then plug the mouse back in, but doing that every time is getting old.

Any simple solutions?

Avatar image for Amster_G
#2 Posted by Amster_G (4329 posts) -

I don't have an answer for your problem but I'm having a very similar issue.

This pretty much happens to me as well when I have my Android phone connected to the computer (USB). Restarting takes a while longer and I can't get through the 'Welcome' screen. It literally hangs for as long as the phone is still connected. Once I unplug it, the computer proceeds to desktop.

Avatar image for General_X
#3 Posted by General_X (9137 posts) -
It might be worth checking to see if the BIOS is set to boot from a USB Device at all, this might be a reason since it may be checking all the USB ports before booting from the HDD.
Avatar image for JohnF111
#4 Posted by JohnF111 (14187 posts) -
Happened to me, in your BIOS disable the USB Boot function, don't know where it might be or what it might be called for your BIOS but disable it anyway and then when you boot up again it probably will be slow again but when you're in Windows unplug then replug all your devices(USB) then reboot, hopefully if like my problem it should go away and never return unless you reset the BIOS of course.
Avatar image for Zopple
#5 Posted by Zopple (31 posts) -

Happened to me, in your BIOS disable the USB Boot function, don't know where it might be or what it might be called for your BIOS but disable it anyway and then when you boot up again it probably will be slow again but when you're in Windows unplug then replug all your devices(USB) then reboot, hopefully if like my problem it should go away and never return unless you reset the BIOS of course.JohnF111

This sorted it, great suggestion, thanks. Only issue is the keyboard doesn't work until post-POST so to reach the BIOS screen I'll have to reset the BIOS with the CMOS jumper then update it again, as I can't hit F9... though hopefully I won't have to do that for a while. Thanks again.

edit: Thinking about it I'm not sure if I disabled 'Boot from USB', and I just disabled the USB ports until Windows loads... Oh well, it works :P

Avatar image for JohnF111
#6 Posted by JohnF111 (14187 posts) -

[QUOTE="JohnF111"]Happened to me, in your BIOS disable the USB Boot function, don't know where it might be or what it might be called for your BIOS but disable it anyway and then when you boot up again it probably will be slow again but when you're in Windows unplug then replug all your devices(USB) then reboot, hopefully if like my problem it should go away and never return unless you reset the BIOS of course.Zopple

This sorted it, great suggestion, thanks. Only issue is the keyboard doesn't work until post-POST so to reach the BIOS screen I'll have to reset the BIOS with the CMOS jumper then update it again, as I can't hit F9... though hopefully I won't have to do that for a while. Thanks again.

Ah... unfortunate side effect, but at least the slow booting is sorted. My keyboard doesn't power up until a few milliseconds before the BIOS screen goes away so I have to tap my F8 button and hope the signal was picked up in time to get to my BIOS.