SWTOR Won't launch no matter what fixes I try, help!

This topic is locked from further discussion.

Avatar image for supercredit
#1 Posted by supercredit (51 posts) -

every time I try to launch The old Republic, it doesn't do anything. Then, the process won't end so I have to restart my computer just to try again.

I've tried fixing the launcher, re-installing, updating graphics driver, deleting patch folder, everything. I don't get it!

And Just so nobody asks, my pc specs are more than enough to run it. 8gigs ram, I5 3.3gh processor, gt240 graphics card. I can skyrim on highest and it's fine. So no issues with my hardware.

Anyway, I'm still trying to figure out what's going wrong here, any other tips would be great thanks.

Avatar image for Legendaryscmt
#2 Posted by Legendaryscmt (12532 posts) -

Do you have any programs running as you try to launch the game?

Avatar image for Realmjumper
#3 Posted by Realmjumper (692 posts) -
Are you able to ctrl+alt+delete to shut it down SWTOR?
Avatar image for supercredit
#4 Posted by supercredit (51 posts) -

No other programs running no.

And No, when i cntl alt delete i go to processes, and even though i "end process" it won't end, no matter what I do, so I can't try running it again until I restart my computer.

I noticed, when I downloaded the installer again, i run it, it installs very quickly, and then has to patch. Then it will open the launcher.

Only problem is...I dont wanna have to keep doing that. it has to re-download the whatever gig patch EVERY time I try that.

Avatar image for FelipeInside
#5 Posted by FelipeInside (28269 posts) -
- Uninstall the programs using Revo Uninstaller (Advanced Mode)\ - Delete all registry entries for SWTOR - Restart PC - Reinstall