star wars battlefront II lan problem

This topic is locked from further discussion.

Avatar image for name294
#1 Posted by name294 (1463 posts) -

whenever i host a game at LAN, my brother cant join. we're both using the same router, and neither of us can see each other's games. whats wrong?

firewall is turned off on both of our computers, and no program is blocking it.

oh yeah, and we can play lan together fine on age of empires 3.

my computer is window vista, and his is xp.

Avatar image for joshuahaveron
#2 Posted by joshuahaveron (2165 posts) -

you made sure that the windows firewall is disabled?

Avatar image for name294
#3 Posted by name294 (1463 posts) -
yessir
Avatar image for joshuahaveron
#4 Posted by joshuahaveron (2165 posts) -

you both patched up the game?

Avatar image for imprezawrx500
#5 Posted by imprezawrx500 (19187 posts) -
can they see each other in windows? make sure the source is set to lan not internet.
Avatar image for HELPMEMASTER
#6 Posted by HELPMEMASTER (25 posts) -
I have a windows xp computer, which works fine in single player. However, it doesn't go into multiplayer. It crashes back to the desktop after it loads the map... Any suggestions. It worked fine on my vista. Also, when I am using a portable hotspot (mifi), the xp worked fine to multiplayer. When trying to use an adhoc network, it doesn't work... HELP ME NOW>>>>
Avatar image for HELPMEMASTER
#7 Posted by HELPMEMASTER (25 posts) -
it doesn't work when it is both lan and internet modes anyway...