Rome Total War problem

Avatar image for Mickeyminime
#1 Edited by Mickeyminime (1445 posts) -

I've got a problem. I've been playing the game a while and i've never recalled this problem, glitch or bug before.

Some point in the game, the senate will demand you to kill your faction leader.

After i refused, everyone was my enemy, that was until i decided to make peace/alliance with a none roman faction (Germania) and the other two families, Scipii and Brutii became neutral and only the Senate was my enemy.

However, this is where i have a big problem which i can't seem to solve. I still can't attack the other two roman factions, but they can still attack me. I thought destroying Rome would solve it, but it didn't. Everytime i click attack on one of the two factions, i still get the tick blured out telling me i can't attack them like it was before when you start the game.

Everytime they besiege a city, i can't do anything, all they have to do is sit and wait until the turns hit 0 for me to lose the city without a fight. The only time i can attack them is when they actually decide to attack, but if they don't want to attack, all i can do is stand there and do nothing.

I did have a fight with one of them on the battlefield, but they still remain neutral on the diplomacy table. So it's leaving me in a ugly position as to what it is that i can do.

Has anyone else had this problem.

Avatar image for blazepanzer24
#2 Posted by Blazepanzer24 (195 posts) -

I've never really had this problem myself, though it's been years since I've played the original Rome, total war.

If you bought it on steam you might try and check the integrity of the files. To do this you Right click on the game in your steam library, then select properties. You should see a tap pop up, go the Local files selection, then select view integrity of the game files. What this will do is scan your game's files, and correct or re-download any files that fail the inspection.

When I run into a problem or glitch in a game, this is one of the first things I do, and you'd be surprised how many issue this process has cleaned up for me. However, if it doesn't, then it might be a flaw in the game, and they might not be much you can do.