Roller Coaster Tycoon 3 Vista Problem

This topic is locked from further discussion.

Avatar image for italialuigi
#1 Posted by italialuigi (25 posts) -
I installed the game just fine, but when I try to play it I get this error message. Are there any patches that I can install or anything else to fix the problem? "Microsoft Visual C++ Runtime Library Runtime Error! Program: C:\Program Files\Atari\RollerCoaster Tycoon 3\RCT3.exe abnormal program termination I've already tried changing the compatability to both XP & Win 98, but it still won't work. I was also unsuccessful when I ran it as the administrator. I tried doing both of them at the same time too :(
Avatar image for brandontwb
#2 Posted by brandontwb (4325 posts) -
[QUOTE="italialuigi"]I installed the game just fine, but when I try to play it I get this error message. Are there any patches that I can install or anything else to fix the problem? "Microsoft Visual C++ Runtime Library Runtime Error! Program: C:\Program Files\Atari\RollerCoaster Tycoon 3\RCT3.exe abnormal program termination I've already tried changing the compatability to both XP & Win 98, but it still won't work. I was also unsuccessful when I ran it as the administrator. I tried doing both of them at the same time too :(

Hmm.. I ran RCT3 on Vista yesterday fine. Do you have 64 bit?
Avatar image for italialuigi
#3 Posted by italialuigi (25 posts) -
[QUOTE="brandontwb"][QUOTE="italialuigi"]I installed the game just fine, but when I try to play it I get this error message. Are there any patches that I can install or anything else to fix the problem? "Microsoft Visual C++ Runtime Library Runtime Error! Program: C:\Program Files\Atari\RollerCoaster Tycoon 3\RCT3.exe abnormal program termination I've already tried changing the compatability to both XP & Win 98, but it still won't work. I was also unsuccessful when I ran it as the administrator. I tried doing both of them at the same time too :(

Hmm.. I ran RCT3 on Vista yesterday fine. Do you have 64 bit?

No, I have 32-bit
Avatar image for brandontwb
#4 Posted by brandontwb (4325 posts) -
[QUOTE="italialuigi"][QUOTE="brandontwb"][QUOTE="italialuigi"]I installed the game just fine, but when I try to play it I get this error message. Are there any patches that I can install or anything else to fix the problem? "Microsoft Visual C++ Runtime Library Runtime Error! Program: C:\Program Files\Atari\RollerCoaster Tycoon 3\RCT3.exe abnormal program termination I've already tried changing the compatability to both XP & Win 98, but it still won't work. I was also unsuccessful when I ran it as the administrator. I tried doing both of them at the same time too :(

Hmm.. I ran RCT3 on Vista yesterday fine. Do you have 64 bit?

No, I have 32-bit

I dont know then, try re-installing it.
Avatar image for italialuigi
#5 Posted by italialuigi (25 posts) -
[QUOTE="italialuigi"][QUOTE="brandontwb"]Hmm.. I ran RCT3 on Vista yesterday fine. Do you have 64 bit?brandontwb
No, I have 32-bit

I dont know then, try re-installing it.

I tried re-installing it 2 times already :(
Avatar image for italialuigi
#6 Posted by italialuigi (25 posts) -
Bump! :)
Avatar image for brade001
#7 Posted by brade001 (25 posts) -
I installed RCT3 fine, and it all works but when i go on the actuall game, u know like career or sandbox mode, you can hardly see anything. u can see some rides and the main entrance but only as sillhouettes. I dont get it, everything works you just cant see what ur doing. i have windows vista home premium by the way.
Avatar image for brade001
#8 Posted by brade001 (25 posts) -
CAN ANYONE HELP ME WITH MY PROBLEM
Avatar image for shanedolan
#9 Posted by shanedolan (25 posts) -
thats the same thing that happens with mine... everything works but when you go to the career mode and stuff i can see the trees and the outlines of some rides and the park entrance but the ground, rides and paths are all black
Avatar image for deathshand707
#10 Posted by deathshand707 (955 posts) -

Try updating miscrosoft visual c++ to the latest version. Make sure all your video and audio drivers are updated. And make sure windows is updated first.