Problem with OpenGL when trying to run Chronicles of Riddick on 8800GTS

This topic is locked from further discussion.

Avatar image for tomasz79tomasz
#1 Posted by tomasz79tomasz (25 posts) -
When I try to run The Chronicles of Riddick (it`s developer`s cut version) on my amd 4800, 2Gb ram nad 8800GTS (under win XP, with new drivers from nvidia site, and directx 9.0c installed) I got aplication error and it sais this game needs drivers with support of OpenGL 1.3 or something like that...

Do I need to install an openGL equivallent of directx or what?
Avatar image for Crosader
#2 Posted by Crosader (520 posts) -
Have you tried updating the game? I got that problem, when I first installed it.
Avatar image for alexr
#3 Posted by alexr (918 posts) -

When I try to run The Chronicles of Riddick (it`s developer`s cut version) on my amd 4800, 2Gb ram nad 8800GTS (under win XP, with new drivers from nvidia site, and directx 9.0c installed) I got aplication error and it sais this game needs drivers with support of OpenGL 1.3 or something like that...

Do I need to install an openGL equivallent of directx or what?tomasz79tomasz

You mean maybe this one:

SbZEngine.exe Error? OpenGL 1.3 or higher?!

Avatar image for tomasz79tomasz
#4 Posted by tomasz79tomasz (25 posts) -

[QUOTE="tomasz79tomasz"]When I try to run The Chronicles of Riddick (it`s developer`s cut version) on my amd 4800, 2Gb ram nad 8800GTS (under win XP, with new drivers from nvidia site, and directx 9.0c installed) I got aplication error and it sais this game needs drivers with support of OpenGL 1.3 or something like that...

Do I need to install an openGL equivallent of directx or what?alexr

You mean maybe this one:

SbZEngine.exe Error? OpenGL 1.3 or higher?!

 

No, it`s this exactly: "This aplication requires graphic driver support for OpenGL 1.3 or higher."

 

I`ll try to update it and see what happens 

Avatar image for TacticalElefant
#5 Posted by TacticalElefant (900 posts) -
Try actually downloading OpenGL 2.0.
Avatar image for tomasz79tomasz
#6 Posted by tomasz79tomasz (25 posts) -

Try actually downloading OpenGL 2.0.TacticalElefant

 

Ok, tried and installed this one from here:   http://www.versiontracker.com/php/dlpage.php?id=18800&db=win&pid=19770&kind=&lnk=http%3A%2F%2Fdownload.microsoft.com%2Fdownload%2Fwin95upg%2Finfo%2F1%2FW95%2FEN-US%2FOpengl95.exe

 

and its just the same...   what the...? 

Avatar image for Crosader
#7 Posted by Crosader (520 posts) -
I ask again... Have you updated the game? Because I had the same problem until I updated it with the latest patch.
Avatar image for Jack_Summersby
#8 Posted by Jack_Summersby (1444 posts) -
I am playing COR with the 1.1 patch on XP with an 8800 GTS 640 MB GPU.
Avatar image for alexr
#9 Posted by alexr (918 posts) -
Dude! I had the same problem like you! You need a special Patch. I had forget what's the name of this patch, but it existed! I searched this patch by GOOGLE. Somewhere.
Avatar image for c_doody_1999
#10 Posted by c_doody_1999 (517 posts) -

Simplest solution ever,

i had this problem on a 7600 gt, download the patch for the game, think i even got it from gamespot, this fixes the problem