PC Mode on My TV Looks Terrible (Please Help Me!)

Avatar image for snpzfresh-
SnPzFresh-

14

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#1 SnPzFresh-
Member since 2019 • 14 Posts

Hello, I'm going to cut straight to the chase. My Toshiba 32c120u 2012 (720p) TV Moniter, has an option called PC Mode. Which turns off all post processing effects. I've been playing on a mode called Dynamic, for a long time. It has a lot of Edge Enhancement, and that's why i was wondering, why my games looked so jagged! So i saw some Topics, and they said use PC Mode or Game mode (My TV only has PC mode) for Gaming. So i switched to PC mode, and good lordddd. My screen looked like doodoo, my blacks were washed out, my whites looked grey. My color was terrible. It didn't look right. But Jaggies disappeared, and i was so excited! But the colors were off, So please can anyone of you help me figure out the issue, to make my TV pop without switching to dynamic, cause you can't turn off post processing effects individually. You can only switch modes, which is terrible!

Avatar image for BassMan
BassMan

10728

Forum Posts

0

Wiki Points

0

Followers

Reviews: 126

User Lists: 0

#2 BassMan  Online
Member since 2002 • 10728 Posts

@snpzfresh-: Adjust your image settings like contrast, brightness, gamma, etc. once you have switched to PC mode. It will probably save the settings specific to that mode if it is a decent TV.

Avatar image for snpzfresh-
SnPzFresh-

14

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#3 SnPzFresh-
Member since 2019 • 14 Posts

@BassMan: Yup i've turned the contrast up, and calibrated the brightness. It was so washed out, maybe i should change the RGB Format. Maybe PC mode uses 0:255

Avatar image for snpzfresh-
SnPzFresh-

14

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#4 SnPzFresh-
Member since 2019 • 14 Posts

@BassMan: I think i just fixed it! I switched the RGB Format to RGB Full, and i could still see blacks. The colors are sharp now.

Avatar image for BassMan
BassMan

10728

Forum Posts

0

Wiki Points

0

Followers

Reviews: 126

User Lists: 0

#5 BassMan  Online
Member since 2002 • 10728 Posts

@snpzfresh- said:

@BassMan: I think i just fixed it! I switched the RGB Format to RGB Full, and i could still see blacks. The colors are sharp now.

Good stuff. :)

Avatar image for snpzfresh-
SnPzFresh-

14

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#6 SnPzFresh-
Member since 2019 • 14 Posts

@BassMan: Yeah thx again!