Nvidia GeForce 310.xx driver pulled?

This topic is locked from further discussion.

Avatar image for GamerwillzPS
#1 Posted by GamerwillzPS (8531 posts) -

I can remember receiving a notification from the Control Panel about a new driver being available and didn't bother to download it. At this time I remembered about it and intended to download it now, but it's unable to get the latest driver. I also checked Nvidia's website and the latest driver appeared to be my current one.

What's going on? Did any of you manage to get the 310.xx driver?

Avatar image for C_Rule
#2 Posted by C_Rule (9816 posts) -
There's a few 310.xx beta drivers. The most recent being 310.70 which was released on the 4th.
Avatar image for darksusperia
#3 Posted by darksusperia (6945 posts) -
its still listed but under beta.. http://www.nvidia.com/object/win8-win7-winvista-64bit-310.70-driver.html
Avatar image for GamerwillzPS
#4 Posted by GamerwillzPS (8531 posts) -

its still listed but under beta.. http://www.nvidia.com/object/win8-win7-winvista-64bit-310.70-driver.htmldarksusperia

Ah, that explains it.

I wonder why the Control Panel brought a beta driver up? A mistake on the Nvidia's part?

Avatar image for darksusperia
#5 Posted by darksusperia (6945 posts) -

[QUOTE="darksusperia"]its still listed but under beta.. http://www.nvidia.com/object/win8-win7-winvista-64bit-310.70-driver.htmlGamerwillzPS

Ah, that explains it.

I wonder why the Control Panel brought a beta driver up? A mistake on the Nvidia's part?

you can set the update software to check for beta drivers as well as the whql in the preferences. Maybe you enabled it but didnt realise?
Avatar image for GamerwillzPS
#6 Posted by GamerwillzPS (8531 posts) -

[QUOTE="GamerwillzPS"]

[QUOTE="darksusperia"]its still listed but under beta.. http://www.nvidia.com/object/win8-win7-winvista-64bit-310.70-driver.htmldarksusperia

Ah, that explains it.

I wonder why the Control Panel brought a beta driver up? A mistake on the Nvidia's part?

you can set the update software to check for beta drivers as well as the whql in the preferences. Maybe you enabled it but didnt realise?

Oh, I have it disabled. Thanks for the heads up anyway.

Avatar image for dramaybaz
#7 Posted by dramaybaz (6020 posts) -
Hmm I downloaded the beta a couple of days ago, then on the 4th, I was prompted by the nvidia panel to download drivers, which linked to the non beta section. I installed them as well, but seems they were the exact same?