My Watch Dogs moan

This topic is locked from further discussion.

Avatar image for deactivated-579f651eab962
#1 Posted by deactivated-579f651eab962 (5404 posts) -

I just want to play the game dammit. Here's what happens when I do.

and yes I've tried disabling SLI, tried everything.

Fed up with waiting for patches! This is just a vent thread, join me wont you....

Avatar image for zanelli
#2 Posted by zanelli (1063 posts) -

Hmm looks like this it could be to do with data streaming. Have you got this installed on your SSD?

I've seen this happen on some open world games that are installed on slower drives.

Avatar image for PredatorRules
#3 Edited by PredatorRules (11946 posts) -

I'd suggest you to try different driver but I don't think you're a noobie about such things so, meh, it's a broken mess.

Avatar image for 7mdma
#4 Edited by 7MDMA (315 posts) -

There are definetely some solutions for you to consider. I've managed to optimize my Watchdogs experience a ton and even enhance it to boot.

  • Firstly, dont even bother downloading any official Ubisoft patches; if you have already, roll-back as they manage to make the stuttering even worse.
  • Find one of the unofficial unlocks or "mods" such as the "worse mod" that will add certain settings that were disabled in the vanilla version to your game http://www.guru3d.com/files_details/watch_dogs_theworse_mod_8_download.html. I'm not sure about the latest version (this) but the one I use was an earlier version and it drastically reduced stutter while adding things like headlight shadows, nicer bloom and bokeh DOF (which is a matter of taste for some) and denser weather effects and lights. Basically, it enhanced my game visually and erased most of the stutter at the same time, as absurb as that seems. I've got my patch files that optimized my game if those dont work for you.
  • You absolutely have to have textures on high to mitigate stutter. It's also important to set LOD on high. The other settings aren't so important.
  • Press start, search, device manager, click on disk drives and your hard drive, click on policies and make sure write caching is enabled on the device.
  • Press start, search, %TEMP% and remove everything.
  • Defragment your Watchdogs folder or entire hard-drive.
  • Run a registry cleaner like CCleaner.
  • Make sure there's no unessential crap running in task manager before your run Watchdogs.

Hopefully this will optimize your game, even to some extent and apologies in advance if you've tried all that and still struggling with stuttering. To be honest, the problem still hasn't been 100 % eliminated on my side but it's barely noticeable anymore.

-

Avatar image for deactivated-579f651eab962
#5 Posted by deactivated-579f651eab962 (5404 posts) -

@7mdma said:

There are definetely some solutions for you to consider. I've managed to optimize my Watchdogs experience a ton and even enhance it to boot.

  • Firstly, dont even bother downloading any official Ubisoft patches; if you have already, roll-back as they manage to make the stuttering even worse.
  • Find one of the unofficial unlocks or "mods" such as the "worse mod" that will add certain settings that were disabled in the vanilla version to your game http://www.guru3d.com/files_details/watch_dogs_theworse_mod_8_download.html. I'm not sure about the latest version (this) but the one I use was an earlier version and it drastically reduced stutter while adding things like headlight shadows, nicer bloom and bokeh DOF (which is a matter of taste for some) and denser weather effects and lights. Basically, it enhanced my game visually and erased most of the stutter at the same time, as absurb as that seems. I've got my patch files that optimized my game if those dont work for you.
  • You absolutely have to have textures on high to mitigate stutter. It's also important to set LOD on high. The other settings aren't so important.
  • Press start, search, device manager, click on disk drives and your hard drive, click on policies and make sure write caching is enabled on the device.
  • Press start, search, %TEMP% and remove everything.
  • Defragment your Watchdogs folder or entire hard-drive.
  • Run a registry cleaner like CCleaner.
  • Make sure there's no unessential crap running in task manager before your run Watchdogs.

Hopefully this will optimize your game, even to some extent and apologies in advance if you've tried all that and still struggling with stuttering. To be honest, the problem still hasn't been 100 % eliminated on my side but it's barely noticeable anymore.

-

^I bet Ubi support told you that.^

It's installed on my 500GB Evo, tried different drivers (obviously). I did use the "worse mod" before the current patch but it didn't help the stuttering. This is a fresh install of windows about 3 weeks ago, it's not the OS or fragmentation *SSD.

I've spent many hours with the game and i'm not even into 2nd mission, spent more time fiddling with it than playing the bloody thing.

Shame on you UBISOFT.......shame on you.

Reaction GIF: facepalm, disappointed, Conan O'Brien

Avatar image for Byshop
#6 Posted by Byshop (18271 posts) -

@klunt_bumskrint: I had a similar issue on my AMD 7990 using the beta 14.6 drivers. I realize you are probably on Nvidia since you said SLI, but the issue I had looked pretty much exactly like what I see in that video. Backing off to the earlier 14.4 drivers fixed it for me.

-Byshop

Avatar image for zanelli
#7 Posted by zanelli (1063 posts) -

I've read some people have fixed this problem by using the boarderless windowed mode with Nvidia cards. Might be worth giving a go, if you haven't already.

Avatar image for deactivated-579f651eab962
#8 Posted by deactivated-579f651eab962 (5404 posts) -

@zanelli said:

I've read some people have fixed this problem by using the boarderless windowed mode with Nvidia cards. Might be worth giving a go, if you haven't already.

Have already Zan, thanks anyway

Avatar image for soolkiki
#9 Posted by soolkiki (1783 posts) -

ooo! I couldn't even finish the video. That was painful. :( Sorry to see this happen to you, man!

Avatar image for Coseniath
#10 Edited by Coseniath (3183 posts) -

Hello Klunt_Bumskrint.

This reminds me a lot my stuttering when I was overloading Skyrim with visual mods. My GTX570 with the 1280MB VRAM couldn't handle it. Lots of stuttering when the game was reaching VRAM's limit.

I noticed that just by changin a few things (droppin the VRAM usage to 1150-1200MB) the game was running smoothly.

Since I guess you are using the same program that I use too to monitor VRAM (MSI afterburner or you are using FRAPS...), have you tried to reduce the settings in order to use around 2700-2800MB VRAM? (I assume you have 3072MB, 780 or 780ti)

If this doesn't help, try Watch_Dogs - TheWorse Mod 0.97 Download

People reporting that it removes stuttering, so it might worth a try too.

Avatar image for horgen
#11 Posted by Horgen (116382 posts) -

Turn down to high settings?

Ultra requires 3GB at 1080, no?

Avatar image for jun_aka_pekto
#12 Edited by jun_aka_pekto (22281 posts) -

Mine seems fine even though I have a "crap" CPU, unmodded Ultra, not to mention the game is running off a 2009 SATA WD "Green" HDD.

Loading Video...

Avatar image for deactivated-579f651eab962
#14 Posted by deactivated-579f651eab962 (5404 posts) -

@Chatch09: Don't even go there.

@horgen: 1440 FTW

I've tried the latest worse mod (0.97c) does seem to help a bit on single gpu but not on SLI

Avatar image for Coseniath
#15 Posted by Coseniath (3183 posts) -

@klunt_bumskrint: Have you tried lowering the visuals in order to use less VRAM? :P

Avatar image for GTR12
#16 Posted by GTR12 (12571 posts) -

Stupid question, but how the hell do you manage to drive so well with all the stuttering?

Avatar image for wis3boi
#18 Posted by wis3boi (32507 posts) -

was gonna say use the E3 mod, but looks like you already did. That contains a bunch of stutter and texture fixes

Avatar image for JigglyWiggly_
#19 Posted by JigglyWiggly_ (24599 posts) -

Did you try disabling your overlay?

Avatar image for deactivated-579f651eab962
#20 Posted by deactivated-579f651eab962 (5404 posts) -

@JigglyWiggly_: Yep

Avatar image for kungfool69
#22 Posted by kungfool69 (2584 posts) -

wow, the issue looks exactly like buffering video on a slow internet connection!! surely someone else out there has encountered this issue