My DVD-ROM suddenly ceased to appear in My Computer.

This topic is locked from further discussion.

Avatar image for th3warr1or
#1 Posted by th3warr1or (20640 posts) -

I have no idea when this happened, because I rarely use it.

But as of the past few days, my computer has slowed down a bit during start up when loading the desktop, so I was going to reinstalled Windows. I put the disc in, and it didn't run. So I went into My Computer to run it manually, and I realized that it's not there.

What do I do?

I did a virus scan, and my computer turned up clean.

It's a custom-PC, so I have no idea what to do.

Edit: It shows up in Device Manager (HP DVD Writer 1260t) but says under properties, "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged."

Avatar image for kraken2109
#2 Posted by kraken2109 (13271 posts) -

You could try a different sata port i guess

Avatar image for th3warr1or
#3 Posted by th3warr1or (20640 posts) -

I don't think its a SATA port issue, since I plugged in an external BR-ROM via a USB port, and I got the same problem (doesn't show up in My Computer, has Code 19 in Device Manager).

Avatar image for metacritical
#4 Posted by metacritical (2537 posts) -
googling code 19 gives a lot of help
Avatar image for th3warr1or
#5 Posted by th3warr1or (20640 posts) -

Google was the first thing I tried. This is what I attempted:

Unfortunately, I stopped at step 4 because I do not have "Lower Filters" there at all, which kind of puts a damper on the whole thing. There are 9 things under the respective registry "{4D36E965-E325-11CE-BFC1-08002BE10318}" and none of them are "Lower Filters."

I also attempted just skipping step 4 and going to the "uninstall and reboot" steps, didn't work.

I plugged in an external BR-ROM, and that BR-ROM had the same error.

Ran "sfc /scannow" and all I got was "Windows Resource Protection did not find any integrity violations."

Avatar image for JigglyWiggly_
#6 Posted by JigglyWiggly_ (24610 posts) -
Do you have daemon tools installed? Try uninstalling it.