Medal of Honor Allied Assault Could not load OpenGL subsystem

This topic is locked from further discussion.

Avatar image for darioush1000
#1 Posted by darioush1000 (25 posts) -
Hey guys, I reinstalled MoHAA and i installed a Widescreen patch so I can run in 1440x900 Resolution, but when I start the game I get this from console --- Common Initialization --- Medal of Honor Allied Assault 1.11 win-x86 Mar 5 2002 ----- FS_Startup ----- Current search path: D:\DARIOU~1\MoHAA/main D:\DARIOU~1\MoHAA\main\pak6.pk3 (104 files) D:\DARIOU~1\MoHAA\main\Pak5.pk3 (259 files) D:\DARIOU~1\MoHAA\main\Pak4.pk3 (593 files) D:\DARIOU~1\MoHAA\main\Pak3.pk3 (669 files) D:\DARIOU~1\MoHAA\main\Pak2.pk3 (4722 files) D:\DARIOU~1\MoHAA\main\Pak1.pk3 (772 files) D:\DARIOU~1\MoHAA\main\Pak0.pk3 (11175 files) ---------------------- 18294 files in pk3 files execing default.cfg execing menu.cfg execing newconfig.cfg Config: unnamedsoldier.cfg execing configs/unnamedsoldier.cfg couldn't exec localized.cfg execing autoexec.cfg Unknown command "fov" couldn't exec custom.cfg ...detecting CPU, found Intel Pentium III ------- Input Initialization ------- Initializing DirectInput... Couldn't set DI coop level Falling back to Win32 mouse support... ------- Input Initialization Complete ------- 43 You are now setup for easy mode. ----- Client Initialization ----- Called FadeSound with: 0.000000 ----- Initializing Renderer ---- ----- R_Init ----- Initializing OpenGL subsystem ...initializing QGL ...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): succeeded ...setting mode 8: 1280 1024 FS ...using colorsbits of 32 ...calling CDS: ok ...registered window class ...created window@0,0 (1280x1024) Initializing OpenGL driver ...getting DC: succeeded ...GLW_ChoosePFD( 32, 24, 0 ) ...125 PFDs found ...hardware acceleration found ...PIXELFORMAT 7 selected ...creating GL context: succeeded ...making context current: succeeded Initializing OpenGL extensions ...using GL_EXT_texture_compression_s3tc ...using GL_ARB_texture_compression ...GL_EXT_texture_env_add not found ...using WGL_EXT_swap_control ...using GL_ARB_multitexture ...ignoring GL_EXT_texture_env_combine ...using GL_EXT_compiled_vertex_array ...WGL_3DFX_gamma_control not found GL_VENDOR: NVIDIA Corporation GL_RENDERER: GeForce 9500 GT/PCI/SSE2 GL_VERSION: 3.0.0 GL_EXTENSIONS: GL_ARB_depth_texture GL_EXTENSIONS: GL_ARB_fragment_program GL_EXTENSIONS: GL_ARB_imaging GL_EXTENSIONS: GL_ARB_multisample GL_EXTENSIONS: GL_ARB_multitexture GL_EXTENSIONS: GL_ARB_point_parameters GL_EXTENSIONS: GL_ARB_shadow GL_EXTENSIONS: GL_ARB_texture_border_clamp GL_EXTENSIONS: GL_ARB_texture_compression GL_EXTENSIONS: GL_ARB_texture_cube_map GL_EXTENSIONS: GL_ARB_texture_env_add GL_EXTENSIONS: GL_ARB_texture_env_combine GL_EXTENSIONS: GL_ARB_texture_env_dot3 GL_EXTENSIONS: GL_ARB_texture_mirrored_repeat GL_EXTENSIONS: GL_ARB_transpose_matrix GL_EXTENSIONS: GL_ARB_vertex_buffer_object GL_EXTENSIONS: GL_ARB_vertex_program GL_EXTENSIONS: GL_ARB_window_pos GL_EXTENSIONS: GL_S3_s3tc GL_EXTENSIONS: GL_EXT_abgr GL_EXTENSIONS: GL_EXT_bgra GL_EXTENSIONS: GL_EXT_blend_color GL_EXTENSIONS: GL_EXT_blend_func_separate GL_EXTENSIONS: GL_EXT_blend_minmax GL_EXTENSIONS: GL_EXT_blend_subtract GL_EXTENSIONS: GL_EXT_compiled_vertex_array GL_EXTENSIONS: GL_EXT_draw_range_elements GL_EXTENSIONS: GL_EXT_fog_coord GL_EXTENSIONS: GL_EXT_multi_draw_arrays GL_EXTENSIONS: GL_EXT_packed_pixels GL_EXTENSIONS: GL_EXT_point_parameters GL_EXTENSIONS: GL_EXT_rescale_normal GL_EXTENSIONS: GL_EXT_secondary_color GL_EXTENSIONS: GL_EXT_separate_specular_color GL_EXTENSIONS: GL_EXT_shadow_funcs GL_EXTENSIONS: GL_EXT_stencil_two_side GL_EXTENSIONS: GL_EXT_stencil_wrap GL_EXTENSIONS: GL_EXT_texture3D GL_EXTENSIONS: GL_EXT_texture_compression_s3tc GL_EXTENSIONS: GL_EXT_texture_cube_map GL_EXTENSIONS: GL_EXT_texture_edge_clamp GL_EXTENSIONS: GL_EXT_texture_env_combine GL_EXTENSIONS: GL_EXT_texture_env_dot3 GL_EXTENSIONS: GL_EXT_texture_filter_anisotropic GL_EXTENSIONS: GL_EXT_texture_lod GL_EXTENSIONS: GL_EXT_texture_lod_bias GL_EXTENSIONS: GL_EXT_texture_object GL_EXTENSIONS: GL_EXT_vertex_array GL_EXTENSIONS: GL_IBM_rasterpos_clip GL_EXTENSIONS: GL_IBM_texture_mirrored_repeat GL_EXTENSIONS: GL_KTX_buffer_region GL_EXTENSIONS: GL_NV_blend_square GL_EXTENSIONS: GL_NV_copy_depth_to_color GL_EXTENSIONS: GL_NV_depth_clamp GL_EXTENSIONS: GL_NV_fence GL_EXTENSIONS: GL_NV_float_buffer GL_EXTENSIONS: GL_NV_fog_distance GL_EXTENSIONS: GL_NV_fragment_program GL_EXTENSIONS: GL_NV_half_float GL_EXTENSIONS: GL_NV_light_max_exponent GL_EXTENSIONS: GL_NV_multisample_filter_hint GL_EXTENSIONS: GL_NV_occlusion_query GL_EXTENSIONS: GL_NV_packed_depth_stencil GL_EXTENSIONS: GL_NV_pixel_data_range GL_EXTENSIONS: GL_NV_point_sprite GL_EXTENSIONS: GL_NV_primitive_restart GL_EXTENSIONS: GL_NV_register_combiners GL_EXTENSIONS: GL_NV_register_combiners2 GL_EXTENSIONS: GL_NV_texgen_reflection GL_EXTENSIONS: GL_NV_texture_compression_vtc GL_EXTENSIONS: GL_NV_texture_env_combine4 GL_EXTENSIONS: GL_NV_texture_expand_normal GL_EXTENSIONS: GL_NV_texture_rectangle GL_EXTENSIONS: GL_NV_texture_shader GL_EXTENSIONS: GL_NV_texture_shader2 GL_EXTENSIONS: GL_NV_texture_shader3 GL_EXTENSIONS: GL_NV_vertex_array_range GL_EXTENSIONS: GL_NV_vertex_array_range2 GL_EXTENSIONS: GL_NV_vertex_program GL_EXTENSIONS: GL_NV_vertex_program1_1 GL_EXTENSIONS: GL_NV_vertex_program2 GL_EXTENSIONS: GL_SGIS_generate_mipmap GL_EXTENSIONS: GL_SGIS_texture_lod GL_EXTENSIONS: GL_SGIX_depth_texture GL_EXTENSIONS: GL_SGIX_shadow GL_EXTENSIONS: GL_WIN_swap_hint GL_EXTENSIONS: WGL_EXT_swap_control GL_MAX_TEXTURE_SIZE: 8192 GL_MAX_ACTIVE_TEXTURES_ARB: 4 PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits) MODE: 8, 1280 x 1024 fullscreen hz:60 GAMMA: hardware w/ 0 overbright bits CPU: Intel Pentium III rendering primitives: single glDrawElements texturemode: gl_linear_mipmap_linear picmip: 0 texture bits: 32 multitexture: enabled compiled vertex arrays: enabled texenv add: disabled compressed textures: enabled Initializing Shaders Setting up Shaders ----- finished R_Init ----- ------- profiling DrawBackground methods ------- glDrawPixels w/ BGR: 26310 clocks glDrawPixels w/ RGB: 20655 clocks glTexSubImage2D w/ BGR: 2083050 clocks glTexSubImage2D w/ RGB: 2344365 clocks DrawBackground: using glDrawPixels with RGB data ------------------------------- ------ Force Feedback Initialization ----- Loading ff... ff: Creating feedback device: ff: ...no ff mouse found Failed to load ff dll ------------------------------------------ --------- Force Feedback Shutdown -------- ------------------------------------------ Winsock Initialized Opening IP socket: localhost:12203 Hostname: Darioush-PC IP: 192.168.10.9 ------- Sound Initialization (full) ------- Sound opened using Direct Sound 'Miles Fast 2D Positional Audio' provider opened. Loading global/sound0.txt ------- S_StopAllSounds (stop music) ------- ------- S_StopAllSounds Complete------- ----- Sound Info ----- driver - Miles Fast 2D Positional Audio speaker setup - headphones reverb - OFF samplebits - 16 speed - 44100 ---------------------- ------- Sound Initialization Complete ------- 168 ms Setting up Shaders Loading inventory... ----- Client Initialization Complete ----- 3121 ms --- Common Initialization Complete --- 4565 ms Working directory: D:\DARIOU~1\MoHAA ------- S_StopAllSounds (stop music) ------- ------- S_StopAllSounds Complete------- trFMV::play(), playing EAlogo.RoQ ------- S_StopAllSounds (stop music) ------- ------- S_StopAllSounds Complete------- trFMV::play(), playing 2015intro.RoQ ------- S_StopAllSounds (stop music) ------- ------- S_StopAllSounds Complete------- trFMV::play(), playing intro.RoQ ------- S_StopAllSounds (stop music) ------- ------- S_StopAllSounds Complete------- r_mode will be changed upon restarting. -------- CL_Vid_Restart_f -------- ------- Sound Begin Registration ------- ------- S_StopAllSounds (stop music) ------- ------- S_StopAllSounds Complete------- ------- Sound Begin Registration Complete ------- RE_Shutdown( 1 ) Shutting down OpenGL subsystem ...wglMakeCurrent( NULL, NULL ): success ...deleting GL context: success ...releasing DC: success ...hiding window ...destroying window ...window successfully destroyed ...resetting display ...shutting down QGL ...unloading OpenGL DLL ----- Initializing Renderer ---- ----- R_Init ----- Cmd_AddCommand: r_infostaticmodels already defined Cmd_AddCommand: r_infoworldtris already defined Initializing OpenGL subsystem ...initializing QGL ...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): succeeded ...setting mode 9: 1600 1200 FS ...using colorsbits of 32 ...calling CDS: failed, bad mode ...trying next higher resolution: failed, bad mode ...restoring display settings ...created window@3,22 (1606x1226) Initializing OpenGL driver ...getting DC: succeeded ...GLW_ChoosePFD( 32, 24, 0 ) ...125 PFDs found ...hardware acceleration found ...PIXELFORMAT 7 selected ...creating GL context: succeeded ...making context current: succeeded ...WARNING: fullscreen unavailable in this mode ...setting mode 9: 1600 1200 FS ...using colorsbits of 16 ...calling CDS: failed, bad mode ...trying next higher resolution: failed, bad mode ...restoring display settings ...window already present, CreateWindowEx skipped Initializing OpenGL driver ...WARNING: fullscreen unavailable in this mode ...shutting down QGL ...unloading OpenGL DLL ...assuming '3dfxvgl' is a standalone driver ...initializing QGL ...WARNING: missing Glide installation, assuming no 3Dfx available ...shutting down QGL ----- CL_Shutdown ----- ------- S_StopAllSounds (stop music) ------- ------- S_StopAllSounds Complete------- Called FadeSound with: 0.000000 ------- S_StopAllSounds (stop music) ------- ------- S_StopAllSounds Complete------- ------- Sound Shutdown (full) ------- ------- Sound Shutdown Complete ------- ----------------------- GLW_StartOpenGL() - could not load OpenGL subsystem I have a nvidia geforce 9500GT 1G and dx 10 and up to date. Please HELP!
Avatar image for Irick_cb
#2 Posted by Irick_cb (1691 posts) -
Apparently people have been having problems with _that_ specific resolution. If you start it in safe mode and select a lower resolution it will run, looking to see if i can find any more information. *edit* Okay update: Looks like some of the incidents have been driver based when using vista, see if your drivers are up to date, maybe even try the XP drivers. *edit2* Another fix seems to be adding this to the config: Set r_customheight "900" Set r_customwidth "1440" Set r_mode "-1"
Avatar image for mysteryinc96
#3 Posted by mysteryinc96 (25 posts) -
I have a similar problem. I´m looking for an easy solution without having to dissect my computer. Where do I add those lines to the config? Just on the bottom, or someplace else? I'm using Windows XP. Thanks.