Lag on every game I play.

This topic is locked from further discussion.

Avatar image for LordTrexGuy
#1 Posted by LordTrexGuy (504 posts) -

Recently, I've experienced huge amounts of lag in every game I play. I have:

Intel Pentium 4 2.4Ghz
Nvidia Geforce 6200 512MB
1 GB of Ram

Now I'm sure my computer meets the requirements, sometimes over passing, for every game I play. Even Morrowind lags on my PC, giving 20 FPS and for some reason, lowering the settings INCREASES the lag. I get 15 FPS in almost every game like Company of Heroes, where by default the settings are recommended to somewhat high-ultra yet I get the same framerate at the lowest settings. Battle for Middle Earth 2 runs at 25 FPS until I create around 3 hordes of units when the framerate plummets down to 12-15 FPS. Even Oblivon lags at low-mid settings at 800x600 without mods and the only thing I like to keep high in this game is the view distant which is set to full. Dawn of War lags in battles so much that during battles, it looks like a slideshow even at Medium settings at 1024x768. Everyone else with specs lower than me can play all these games and more at 25-30 FPS with my settings.

Right now, I'm so pissed off that I'm considering throwing this piece of crap PC out of my window but the problem is I really can't get my higher-end laptop back for months so I'm stuck with this. Can anyone tell me what is wrong with my computer? I'm expecting much more out of it. Any help is appreciated.

Avatar image for nilzg
#2 Posted by nilzg (753 posts) -
are you sure you meet the requirements? because your computer is quite old and the geforce 6200 isn't all that great to begin with (even for its time, back in 2002 or something). That RAM would be DDR1 which also is old, let alone the pentium 4... anyway are your drivers 'updated'? edit: I just looked it up and the 6200 is about as 'fast' as my very first gaming card the 4200ti..
Avatar image for ionusX
#3 Posted by ionusX (25760 posts) -

are you sure you meet the requirements? because your computer is quite old and the geforce 6200 isn't all that great to begin with (even for its time, back in 2002 or something). That RAM would be DDR1 which also is old, let alone the pentium 4... anyway are your drivers 'updated'? edit: I just looked it up and the 6200 is about as 'fast' as my very first gaming card the 4200ti..nilzg
yeah time to get a new gpu and probably a cpu brah that machine expired along time ago. probably smells rancid inside

Avatar image for blaznwiipspman1
#4 Posted by blaznwiipspman1 (6776 posts) -

ahh the pentium 2.4ghz that takes me back, it was my first build that i put together actually....mine was a pentium 4 2.6ghz prescott paired with a ATI radeon 9200 AGP plus 512mb of ram. Even had a nice 17inch CRT monitor that cost me close to $200. My favorite games back then were starcraft 1, warcraft 3, and need for speed underground (the very first one)

Avatar image for kraken2109
#5 Posted by kraken2109 (13271 posts) -

You expected more?

That PC would have been low end (gaming wise) in 2003.

Avatar image for Mareczek99
#6 Posted by Mareczek99 (357 posts) -

You expected more?

That PC would have been low end (gaming wise) in 2003.

kraken2109

Well I had a PC like that for a very long time and it played games like Quake 4, Oblivion, at high details the difference though is I had a 6600 GT.

TC - if You want to keep the PC for casual playing and older games - get a 6600GT it should be cheap as hell now.

Avatar image for nilzg
#7 Posted by nilzg (753 posts) -
[QUOTE="Mareczek99"]

[QUOTE="kraken2109"]

You expected more?

That PC would have been low end (gaming wise) in 2003.

Well I had a PC like that for a very long time and it played games like Quake 4, Oblivion, at high details the difference though is I had a 6600 GT.

TC - if You want to keep the PC for casual playing and older games - get a 6600GT it should be cheap as hell now.

Old cards aren't really cheap actually (between 50-200$ used, for the 6800GT) you're better of buying a new system which can cost say 600$ for decent hardware