g-sync not working on lg c9 oled getting screen tearing

Avatar image for locus-solus
locus-solus

1164

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#1 locus-solus
Member since 2013 • 1164 Posts

i've updated my tvs firmware, updated windows 10, updated my nvidia drivers, i have g-sync turned on in nvidia control panel, vsync turn off ingame and in nvidia control panel.

other hardware 2080 ti, i7 5820k, resolution 3840 x 2160 or 4k

games i've tried have been dark souls 3, spyro remake, and okami hd. i'm getting screen tearing in all of them.

Avatar image for BassMan
BassMan

11256

Forum Posts

0

Wiki Points

0

Followers

Reviews: 128

User Lists: 0

#2 BassMan
Member since 2002 • 11256 Posts

It should work with all games. The C9 specifically is showing as G-Sync capable in NVCP?

Avatar image for locus-solus
locus-solus

1164

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#3 locus-solus
Member since 2013 • 1164 Posts

@BassMan: it's enabled in full screen mode yes

Avatar image for BassMan
BassMan

11256

Forum Posts

0

Wiki Points

0

Followers

Reviews: 128

User Lists: 0

#4  Edited By BassMan
Member since 2002 • 11256 Posts

Strange. I would try a different cable or DDU driver uninstall followed by clean install of latest drivers.

Also, make sure the TV is in game mode with deep colour enabled.

Avatar image for locus-solus
locus-solus

1164

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#5 locus-solus
Member since 2013 • 1164 Posts

Spyro set to unlimited framerate fix the problem, had it lock at 60fps. unrelated spyro jumping height is tied to framerate the higher it is the lower your jumps are making some of the jumps almost impossible to make.

Could dark souls 3 framerate being locked to 60fps do to the engine, and okami hd being locked to 30fps in engine be the cause?

i'll go test a few more games out

Avatar image for locus-solus
locus-solus

1164

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#6 locus-solus
Member since 2013 • 1164 Posts

i'm also getting screen tearing in the witcher 3

Avatar image for locus-solus
locus-solus

1164

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#7 locus-solus
Member since 2013 • 1164 Posts

hdmi ultra hd deep color, instant game response, and game mode are all on

Avatar image for locus-solus
locus-solus

1164

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#8 locus-solus
Member since 2013 • 1164 Posts

Turn on Vsync. You need to run both or you’ll get screen tearing. Gsync is for frames below your refresh rate. Vsync is for frames above your refresh rate.

I got this reply on my oled reddit thread is this true? won't turning on both increase input lag?

Avatar image for BassMan
BassMan

11256

Forum Posts

0

Wiki Points

0

Followers

Reviews: 128

User Lists: 0

#9 BassMan
Member since 2002 • 11256 Posts

I always have V-Sync on in the NVCP as it just caps the frame rate to the max refresh rate of the display when G-Sync is enabled. No point in processing frames that are not shown anyway. In-game V-Sync should be set to off.

Avatar image for Addict187
Addict187

1073

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#10 Addict187
Member since 2008 • 1073 Posts

@locus-solus: The issue is that you are going over the 120fps your tv outputs at, so you need to either turn V-Sync on the NV control panel or cap your frame rate to 118 PFS or so with something like Riva Tuner software. FreeSync only works when your frame rate is lower then what your tv can output so you need to cap the frame rate with either of the methods i suggested