Color Issues with Ancient Games (Help me out please)

This topic is locked from further discussion.

Avatar image for Masculus
#1 Posted by Masculus (2878 posts) -

So I was trying to play some old favorites (Sanitarium, Diablo) and I get this grotesque and anoying graphical glitch where the colors get distorded in all sorts of rainbow-ish patterns and I can't seen to finda way to make it go away. It is,I think, a compatibility problem with Windows 7 (32bit). Anyway, does someone here know how to get rid of this crap?

Avatar image for cluclap
#2 Posted by cluclap (888 posts) -

So I was trying to play some old favorites (Sanitarium, Diablo) and I get this grotesque and anoying graphical glitch where the colors get distorded in all sorts of rainbow-ish patterns and I can't seen to finda way to make it go away. It is,I think, a compatibility problem with Windows 7 (32bit). Anyway, does someone here know how to get rid of this crap?

Masculus
Try right clicking on the shortcut and selecting run in 256-color mode. I don't have Win 7 so I dont know if it still has that option but try it.
Avatar image for Masculus
#3 Posted by Masculus (2878 posts) -

[QUOTE="Masculus"]

So I was trying to play some old favorites (Sanitarium, Diablo) and I get this grotesque and anoying graphical glitch where the colors get distorded in all sorts of rainbow-ish patterns and I can't seen to finda way to make it go away. It is,I think, a compatibility problem with Windows 7 (32bit). Anyway, does someone here know how to get rid of this crap?

cluclap

Try right clicking on the shortcut and selecting run in 256-color mode. I don't have Win 7 so I dont know if it still has that option but try it.

Tried that, didn't work.

Avatar image for deactivated-5ac102a4472fe
#4 Posted by deactivated-5ac102a4472fe (7431 posts) -

try running in win 98 compatability mode, usualy fixes it, also try minimizing the games and getthem back up (alt+tab) also seems to do the trick from time to time.

Avatar image for fbidog
#5 Posted by fbidog (413 posts) -

I had the same problem with Starcraft but after a day of work I manage to have it work on win 7 64 bits.Try this for Diablo

http://www.youtube.com/watch?v=YB7KmgeJ9WU

Avatar image for Masculus
#6 Posted by Masculus (2878 posts) -

I had the same problem with Starcraft but after a day of work I manage to have it work on win 7 64 bits.Try this for Diablo

http://www.youtube.com/watch?v=YB7KmgeJ9WU

fbidog

Hmm... didn't work for me.

Avatar image for popeye1128
#7 Posted by popeye1128 (25 posts) -

I had the same problem with Starcraft but after a day of work I manage to have it work on win 7 64 bits.Try this for Diablo

http://www.youtube.com/watch?v=YB7KmgeJ9WU

fbidog
Well, it worked for me on Win 7 64 bit playing Sanitarium. Had the messed up colors (sprites) and simply right clicking on desktop, selecting screen resolution option and leaving the window open when starting the game made it all better. Evidently doing this somehow unlocks the monitor resolution and color bit setting so the game can take over. Thanks!
Avatar image for KalDurenik
#8 Posted by KalDurenik (3768 posts) -

first change the desktop into a classic one (none transparent), then you can right click it and force it to run without all the fancy stuff that windows 7 have. Some times doing a alt tab while in game will fix the issue also.

Not sure if the topic is still around but on the Diablo 1 forum (here on GS/GFAQ) there was a huge topic about this with lots of solutions that worked.