Assassins creed 2 wont launch (windows 8)

This topic is locked from further discussion.

Avatar image for GamingVengeance
#1 Posted by GamingVengeance (1874 posts) -

The game worked perfectly fine on windows 7, I got windows 8 tho the other day and now the game doesnt launch unless i launch it in safe mode and it's also only windowed, tryin to change any of the settings(like resolution, to try to get it full screen) just causes the game to crash, when I run the compatibility troubleshooter it says the game is incompatible but iv tried it in every windows compatibility mode but none of them have worked and it continues to say its incompatible. Iv reinstalled both the game and the uplay launcher but it didn't help, any ideas what i could do.

Iv beat the game before on ps3 but i bought the entire franchise during the steam summer sale planning to play them all right before AC3 launches, any help would be appreciated

Avatar image for II-Siamak-II
#2 Posted by II-Siamak-II (480 posts) -

Sounds like your missing some sort of update from windows such as Directx, runtime, etc... or maybe your graphic card drivers are not compatible and needs to be updated, to be fair it's a brand new windows and thus the reason im not gonna bother upgrading until im forced to.

Avatar image for II-Siamak-II
#3 Posted by II-Siamak-II (480 posts) -

Also completly disable SLI and try it with only 1 of your GTX 670s and report back.

Avatar image for GamingVengeance
#4 Posted by GamingVengeance (1874 posts) -
just tried with sli off and same thing :(
Avatar image for ShadowDeathX
#5 Posted by ShadowDeathX (11618 posts) -
Reinstall it?
Avatar image for GamingVengeance
#6 Posted by GamingVengeance (1874 posts) -
Reinstall it?ShadowDeathX
ya i did twice, reinstalled dx, nvidia drivers too, but no luck
Avatar image for BPoole96
#7 Posted by BPoole96 (22817 posts) -

Right click the .exe file and go to properties and go to the compatibility tab. Set it to run in compatibility mode for Windwos 7 and see if it works

*I'm not even sure if Windows 8 has this function since I am still on W7

Avatar image for GamingVengeance
#8 Posted by GamingVengeance (1874 posts) -

Right click the .exe file and go to properties and go to the compatibility tab. Set it to run in compatibility mode for Windwos 7 and see if it works

*I'm not even sure if Windows 8 has this function since I am still on W7

BPoole96
ya iv tried it with every compatibility mode option. doesnt make a difference
Avatar image for II-Siamak-II
#9 Posted by II-Siamak-II (480 posts) -

I don't know what to say, I personally would switch back to windows 7 and wait till Win 8 is patched up and more stable gaming wise.

Avatar image for Ownsin
#10 Posted by Ownsin (1331 posts) -
I just ran AC2 on my Windows 8 and it ran perfectly. TC it's your computer that has the problem not the OS.
Avatar image for GamingVengeance
#11 Posted by GamingVengeance (1874 posts) -
I just ran AC2 on my Windows 8 and it ran perfectly. TC it's your computer that has the problem not the OS.Ownsin
Obviously, I never said it was was exclusively windows 8s problem, it's just of course very relevant to mention that this problem started when I switched to windows 8
Avatar image for mikeisepic
#12 Posted by mikeisepic (25 posts) -
as i did upgrade to windows 8 i found that none of my games but battlefield 3 and medal of honor warfighter and a few handful of games worked. long story short I went back to windows 7 then clean installed windows 8 now everything works all my games launch expect the ones on the list http://www.hardcore-games.tk/wp/old-games-no-win8.php the list does grow but i have noticed that assassins creed 2 runs very slow on windows 8 so you have to put it into compatibility mode for it to run at more then 20 frames for some reason... anyways to the point did you clean install windows 8 or did you just upgrade install?
Avatar image for Starshine_M2A2
#13 Posted by Starshine_M2A2 (4936 posts) -

Glad I don't use Windows 8 then...

Avatar image for GamingVengeance
#14 Posted by GamingVengeance (1874 posts) -
Oops I meant to update this yesterday, i fixed it by uninstalling AC2, uplay, and the ubisoft game launcher, then reinstalling steam, then reinstalling ac 2, works flawlessly now