PC restarts on high load

Avatar image for PfizersaurusRex
#1 Posted by PfizersaurusRex (1185 posts) -

So I've been having this problem for a while, started with an AMD driver update, PC just restarts when I'm in game, no BSOD or anything, just restart and AMD settings go back to default. Switching to fullscreen instead of borderless mode made the problem disappear for a while, but now it's back when I play Ashes Escalation. Thing is when I run either Prime or Furmark it's stable, but when I run both it crashes almost instantly. Could it be bad PSU? It's about 5 years old now, but it should be an overkill for my system: FX-6300@4.2, 8GB RAM, RX 470 4GB Sapphire Nitro. PSU is Thermaltake SPS-630M (49A single rail).

I'd like to blame AMD but really... What the hell is going on?

Avatar image for howmakewood
#2 Posted by Howmakewood (5527 posts) -

Could be PSU, how are the temperatures on cpu?

Avatar image for PfizersaurusRex
#3 Posted by PfizersaurusRex (1185 posts) -

@howmakewood: Temps are good, 51C cores/60C socket with Prime, less when gaming. GPU temps are also good, low 70s. Furmark pushes the GPU to 130W, I guess that's the GPU only, not the whole card, and in games it's usually up to 110W.

Avatar image for howmakewood
#4 Posted by Howmakewood (5527 posts) -

@PfizersaurusRex said:

@howmakewood: Temps are good, 51C cores/60C socket with Prime, less when gaming. GPU temps are also good, low 70s. Furmark pushes the GPU to 130W, I guess that's the GPU only, not the whole card, and in games it's usually up to 110W.

Then it's most likely one of the three: PSU, ram or power delivery failing on motherboard

Avatar image for BassMan
#5 Edited by BassMan (9431 posts) -
@PfizersaurusRex said:

So I've been having this problem for a while, started with an AMD driver update,

Try rolling back drivers to an earlier version where you did not have this problem. Also, do a complete uninstall of current drivers prior to rolling back.

Avatar image for goldenelementxl
#6 Posted by GoldenElementXL (2400 posts) -

I would say it's the PSU. I had a very similar issue with a Corsair H1050 a year or so ago. If it were a driver or RAM issue, you would get a bsod I would think. The fact that the PC is just resstarting, especially at load tells me the PSU is going bad. It's for sure a power issue imo

Avatar image for PfizersaurusRex
#7 Posted by PfizersaurusRex (1185 posts) -

@goldenelementxl said:

I would say it's the PSU. I had a very similar issue with a Corsair H1050 a year or so ago. If it were a driver or RAM issue, you would get a bsod I would think. The fact that the PC is just resstarting, especially at load tells me the PSU is going bad. It's for sure a power issue imo

I'm still hoping it's MB or RAM, or software maybe, as I plan to change CPU MB RAM and reinstall Windows. But maybe I'll have to change PSU first. Definitely won't go with a "cheap but good" model this time.