Integrated Youtube functionality for Gamespot

Avatar image for vpacalypse
#1 Posted by vpacalypse (581 posts) -

The present video player present on Gamespot has issues loading most times for me.

Is there a possibility to transfer this video playback feature to Youtube (as this works pretty much flawlessly for me)?

I'd like to know whether others experience this problem also, & if anything can be done about?

Avatar image for uninspiredcup
#2 Edited by uninspiredcup (32259 posts) -

They put there videos on youtube.

Pretty much everyone in human existence, including those who pre-date electricity hate Gamespots video player.

Avatar image for horgen
#3 Posted by Horgen (119966 posts) -

@uninspiredcup: I have never had any troubles with the videoplayer here. What are the common issues?

Avatar image for uninspiredcup
#4 Edited by uninspiredcup (32259 posts) -

@horgen said:

@uninspiredcup: I have never had any troubles with the videoplayer here. What are the common issues?

Majority of complaints autoplay,. I've had problem with it not playing.

Just used youtube or read the article and ignored it now. Not that there's many articles to read now. Or videos worth watching.

Avatar image for horgen
#5 Posted by Horgen (119966 posts) -

@uninspiredcup said:
@horgen said:

@uninspiredcup: I have never had any troubles with the videoplayer here. What are the common issues?

Majority of complaints autoplay,. I've had problem with it not playing.

Just used youtube or read the article and ignored it now. Not that there's many articles to read now. Or videos worth watching.

Oh. I think you can turn off autoplay.

Avatar image for jackamomo
#6 Posted by Jackamomo (2157 posts) -

I was going to report this in bug reporting.

Chrome won't play embedded videos since yesterday.

I'm using Opera now. Opera is also negating alot of the problems with page loading causing pages to take up to five minutes to load and maybe a minute before you can click something or scroll.

Avatar image for uninspiredcup
#7 Posted by uninspiredcup (32259 posts) -

@horgen said:
@uninspiredcup said:
@horgen said:

@uninspiredcup: I have never had any troubles with the videoplayer here. What are the common issues?

Majority of complaints autoplay,. I've had problem with it not playing.

Just used youtube or read the article and ignored it now. Not that there's many articles to read now. Or videos worth watching.

Oh. I think you can turn off autoplay.

Yea, you can now.

Avatar image for horgen
#8 Posted by Horgen (119966 posts) -

@jackamomo said:

I was going to report this in bug reporting.

Chrome won't play embedded videos since yesterday.

I'm using Opera now. Opera is also negating alot of the problems with page loading causing pages to take up to five minutes to load and maybe a minute before you can click something or scroll.

Try firefox or vivaldi.

Avatar image for Master_Live
#9 Edited by Master_Live (19325 posts) -

Gamespot: making things needlessly harder for their users since 199?.

Avatar image for jackamomo
#10 Posted by Jackamomo (2157 posts) -

@horgen: Opera is more cleverer resulting in faster load times.

Avatar image for horgen
#11 Posted by Horgen (119966 posts) -

@jackamomo said:

@horgen: Opera is more cleverer resulting in faster load times.

Never liked Opera after version 12.64 or so. I think with version 13 they changed the engine behind it, with it went lots of features that I used that were native to the old engine. I switched to Chrome, never found plugins that properly replaced what I missed. The old engine had troubles loading some pages, like GS for instance.

Avatar image for jackamomo
#12 Posted by Jackamomo (2157 posts) -

@horgen: have your dedicated tech team managed to replicate the video player problem?

Avatar image for horgen
#13 Edited by Horgen (119966 posts) -

@jackamomo said:

@horgen: have your dedicated tech team managed to replicate the video player problem?

As I have had little to no issues I haven't looked into it.

Post about it in bug report if you keep experience a problem with it.

Avatar image for vpacalypse
#14 Posted by vpacalypse (581 posts) -
@horgen said:
@jackamomo said:

@horgen: have your dedicated tech team managed to replicate the video player problem?

As I have had little to no issues I haven't looked into it.

Post about it in bug report if you keep experience a problem with it.

I think I will as video's are still not playing most of the time. Can't think why as I'm running an updated/ unmodified chrome browser on a good pc set-up.

You'd think it'd be easier for everyone (gamespot included) to just by default use the youtube player but maybe it's a money thing?

Avatar image for horgen
#15 Posted by Horgen (119966 posts) -

@vpacalypse said:

I think I will as video's are still not playing most of the time. Can't think why as I'm running an updated/ unmodified chrome browser on a good pc set-up.

You'd think it'd be easier for everyone (gamespot included) to just by default use the youtube player but maybe it's a money thing?

Money and control I think.

Avatar image for jackamomo
#16 Edited by Jackamomo (2157 posts) -

Ah not just me then.

It is youtube player but the option to embed is part of the gs forum code and allows preview windows which youtube does not provide, unless it does. But that would mean html would need to be enabled on posts, which it isn't.

The gs forum code is not good.

Scripting (javascript) runs for around 2 minutes on my chrome browser but is right down to 90 seconds on opera.

The scripting on the gs forums document:ready is heavy.

Easily this is the worst optimised website I'e ever visited and that is even with 30 or so ads being blocked on each page load.

Fixing this player problem will need dev time which means spending money and time optimising this website which I don't think has ever been attempted by CBS Interactive.

[EDIT] On closer inspection it turns out this thread is about videos on articles from the main website. Yeah that player is very choppy for me. No idea of what is driving it though youtube/gs.

Also, youtube does have an option to generate embedded player code.

Avatar image for volsung
#17 Posted by Volsung (261 posts) -

I forgot GS still hosted videos. :/

Avatar image for volsung
#18 Posted by Volsung (261 posts) -
@jackamomo said:

Ah not just me then.

It is youtube player but the option to embed is part of the gs forum code and allows preview windows which youtube does not provide, unless it does. But that would mean html would need to be enabled on posts, which it isn't.

The gs forum code is not good.

Scripting (javascript) runs for around 2 minutes on my chrome browser but is right down to 90 seconds on opera.

The scripting on the gs forums document:ready is heavy.

Easily this is the worst optimised website I'e ever visited and that is even with 30 or so ads being blocked on each page load.

Fixing this player problem will need dev time which means spending money and time optimising this website which I don't think has ever been attempted by CBS Interactive.

GS is like the only website I visit that can get ads past my defenses.

So credit where credit is due.

Avatar image for x_karen_x
#20 Posted by X_Karen_x (500 posts) -

@anon_leaker:

Work fine on my device too.