Why I'm "leaving" Gamespot

Avatar image for lurkyuk
#1 Posted by lurkyuk (101 posts) -

I have a list of websites that I visit once a day when I'm bored and Gamespot has been one of them for years. I'm deleting it from the list today because I'm fed up of all the autoplaying videos with sound. Half of the pages on this site have a video that plays automatically and it's really annoying. Reading about Gabe Newell earlier and I made the mistake of scrolling down too far and it starts to play a Super Mario video, again, with bloody sound. I hope you tone these down in future but for now I'll stick with another gaming website.

Avatar image for angerawr
#2 Edited by angerawr (149 posts) -

Thanks so much, I totally understand your frustration. We are looking into ways to address this but it may take some time to get it implemented. Sorry this answer is not much of an answer. We really appreciate your patience in this and are making moves to address your concerns.

Avatar image for dragoonmike
#3 Posted by dragoonmike (138 posts) -

i'm more mad at you click on a story and a different story then what you picked pops up.

Avatar image for sith_acolyte15
#4 Posted by sith_acolyte15 (5796 posts) -

It's almost amusing how long the "we are looking into it" line has been used on this site. It's the same issues for months or years on end.

Avatar image for Klevmore
#5 Posted by Klevmore (138 posts) -

Yeah, I'm done with this website for now. When this auto play crap is removed, I'll add it back to my bookmarks bar. I can't handle this crap anymore.

Avatar image for flipovic
#6 Edited by flipovic (9 posts) -

I must say I empathize with you, good sir, more than once was I taking a good dump and out of nowhere a stupid video starts playing with loud sounds and I'm all like...man, people will think that I'm having good times in here! =| I just want some nice fast scrolling through some news before the dump is ready to deploy...

Avatar image for magichimp
#8 Posted by magichimp (3 posts) -

I have not had any issues with ads or videos, however.. I had a hard time registering for some reason, I had to do 20 captchas before I realized this was a bug, I had to try two other browsers before I could proceed to register.

Avatar image for angerawr
#9 Posted by angerawr (149 posts) -

@magichimp: Thanks for reporting this. We are aware of a recaptcha bug and it should be fixed by the end of the week. Let us know if you're still having problems with it

Avatar image for BeefoTheBold
#10 Posted by BeefoTheBold (978 posts) -

@angerawr said:

Thanks so much, I totally understand your frustration. We are looking into ways to address this but it may take some time to get it implemented. Sorry this answer is not much of an answer. We really appreciate your patience in this and are making moves to address your concerns.

While I appreciate the fact that someone from Gamespot actually responded on this issue about a half a year back. This is the fourth thread I've found on the front page of the site about autoplay videos with no option to toggle them off.

It's an issue that goes back nearly three years at this point. The idea that it's just taking time to be implemented basically sounds like horseshit at this point if you'll forgive the vulgarity. GS has been given time. Autoplay videos are still a thing regardless of innumerable complaints on the subject.

Avatar image for xekon
#11 Edited by xekon (7 posts) -

You can resolve the autoplay issues by installing the firefox addon "NoScript". As far as I can tell none of the videos are auto playing for me. In no script I whitelisted "gamespot.com", google.com, and googleapis.com but did not whitelist any of the others.

OH! look at that, looks like maybe you can just disable them here now: https://www.gamespot.com/forums/bug-reporting-feedback-1000006/how-to-disable-video-autoplay-in-articles-33442137/