This topic is locked from further discussion.

Avatar image for larkanderson
#1 Edited by larkanderson (2227 posts) -

We're continuing to work on preparing for E3 (we've been doing a ton of work to build the pages, prepare the site to handle the server load, etc.) which has been our number one priority, but nonetheless we continue to make changes as normal, though in a reduced capacity!

Features of Note

Making it easier to go from one article/video to another

We're currently running some testing of different variations on our news article and video pages to see if we can make it easier to get from one article or video to another. We're using relatively small sample sizes, but if you suddenly find yourself in a page layout you haven't seen before, it just means you won the testing lottery!

Everyone should now be able to change their notification settings

We believe we've finally tracked down and fixed the bug that prevented some of our users from changing their notification settings (cc @s_h_a_d_o, @robotopbuddy, @charlesolmed)

We're now showing the most specific release date that we have in the gamespace

This used to say March 2014
This used to say March 2014

Other Changes

Please note that this isn't intended to be a list of ALL the changes we make (we work on a lot more than this, srsly), but rather a list of changes that will directly affect or be seen by our members.

  • Fixed a bug that caused the copyright year in our footer to be wrong ಠ_ಠ
  • Fixed a bug that prevented games like Driveclub or Call of Duty: Advanced Warfare from showing up in search
Avatar image for robotopbuddy
#2 Edited by RobotOpBuddy (65496 posts) -

@LarkAnderson: Still not working I'm afraid - they're still not changing, instead reverting back, upon the changes being saved and clearly isn't working for some other users either - see here and here.

In addition to that, it would appear notifications themselves aren't sending reliably - while I am still getting some notifications, I did not get one for this post/thread. If they were edited in afterwards, it's possible that is why; if not though then that's going to need some investigation as well. This thread also mentions the same problem.

Avatar image for anarayan
#3 Posted by anarayan (351 posts) -

Hey Lark, sorry to post about this again, but the site is unable to populate the edit page of my large (near or over 100 games) stacks. When I try to click on the "Edit This Stack" button, only a few games are listed in the page that loads up, and many (actually most) of the games are missing. The edit page doesn't populate it with the whole list of games in the stack. Now given that the site can only list the first 100 games in each stack due to a known bug, I am unable to view/edit all the games in the stack. Is there any fix to this? Thanks!

Avatar image for larkanderson
#4 Posted by larkanderson (2227 posts) -

@robotopbuddy: Thanks! This is super helpful, and we've now been able to identify another issue that is causing this for a smaller subset of users.

Avatar image for larkanderson
#5 Edited by larkanderson (2227 posts) -

@anarayan: We've actually just now pushed out a fix for one of the bugs around this--you can now view a Stack with 100+ games in it and see pages 2+. We'll be working on the other bug (you're unable to load your entire 100+ game Stack in edit mode) next.

Avatar image for anarayan
#7 Posted by anarayan (351 posts) -

@LarkAnderson said:

@anarayan: We've actually just now pushed out a fix for one of the bugs around this--you can now view a Stack with 100+ games in it and see pages 2+. We'll be working on the other bug (you're unable to load your entire 100+ game Stack in edit mode) next.

That's awesome! I am able to see all the games now. Hope the edit function is fixed soon. Thanks Lark!

Avatar image for angeldeb82
#8 Posted by angeldeb82 (1510 posts) -

Well, for some reason, I got logged out after many hours. I was able to log back in, and my profile on the top-right corner of the page is glitched. Does anyone know why? :(

Avatar image for robotopbuddy
#9 Edited by RobotOpBuddy (65496 posts) -
@angeldeb82 said:

Well, for some reason, I got logged out after many hours. I was able to log back in, and my profile on the top-right corner of the page is glitched. Does anyone know why? :(

Can you be more specific on what you mean by 'glitched'?

Avatar image for jp_
#10 Posted by JP_ (12875 posts) -

@robotopbuddy said:

Can you be more specific on what you mean by 'glitched'?

I believe He means the PM area


@angeldeb82 said:

Well, for some reason, I got logged out after many hours. I was able to log back in, and my profile on the top-right corner of the page is glitched. Does anyone know why? :(

If you mean on the PM's. They been out of whack for a while now and we know the Team is working on fixing the problem. If you mean when you get logged out : This has been happening to me as well and Im trying to see what could be causing this hopefully @LarkAnderson might have a idea

Avatar image for angeldeb82
#11 Posted by angeldeb82 (1510 posts) -

@jp_ said:

@robotopbuddy said:

Can you be more specific on what you mean by 'glitched'?

I believe He means the PM area

@angeldeb82 said:

Well, for some reason, I got logged out after many hours. I was able to log back in, and my profile on the top-right corner of the page is glitched. Does anyone know why? :(

If you mean on the PM's. They been out of whack for a while now and we know the Team is working on fixing the problem. If you mean when you get logged out : This has been happening to me as well and Im trying to see what could be causing this hopefully @LarkAnderson might have a idea

I meant the "Login/Join" glitch.

Avatar image for robotopbuddy
#12 Posted by RobotOpBuddy (65496 posts) -

@angeldeb82: If it's showing up login/join in the top-right corner only briefly then I've had that as well, however I've yet to have to actually stay like that for more than 1-3 seconds. If that's all it is then it could just be the server being a little slow or something else delaying the process of displaying user details/checking you're logged in. If it's still showing as login/join a fair while after page load despite being logged in though then it's possible that something is failing somewhere in the process of displaying the logged-in-user info.

Avatar image for SolidSnake35
#13 Posted by SolidSnake35 (58797 posts) -

Oh lawd, changes are taking place at a reduced capacity. I hope you get back to your usual blinding speed soon. Maybe when all engines are firing again the 'top posters' counter on the Off-topic page will be fixed. Or maybe it'll stay like that for another year.

Avatar image for s_h_a_d_o
#14 Posted by s_h_a_d_o (1317 posts) -

@LarkAnderson said:

We believe we've finally tracked down and fixed the bug that prevented some of our users from changing their notification settings (cc @s_h_a_d_o, @robotopbuddy, @charlesolmed)

Well, I have been able to change/save my settings, but I don't know whether they actually work, e.g. I never received notification that you'd mentioned me here (even though that is enabled for my account). :|