Video Player: This video has an invalid file format

Avatar image for NicksCorner
#1 Posted by NicksCorner (27 posts) -

I wanted to check out Greg Kasavin's old review of the old game Knights of the Old Republic but was met with an error message. Funny thing is; Ad does start to play, but with only sound, no picture. Afterwards, nothing.

I tried to view on both Firefox, Firefox incognito, IE and Chrome with no success.

Avatar image for angerawr
#2 Posted by angerawr (165 posts) -

@NicksCorner: So sorry about this, we recently updated our player to support html 5 which means that very old videos that were based in flash no longer work :(

Avatar image for bradius
#3 Posted by bradius (109 posts) -

is there a fix for this? every new video uploaded i cant watch.

Avatar image for wemmick
#4 Edited by wemmick (372 posts) -

@bradius: The bug mentioned above was for very old videos. If you're having trouble with new videos, that's a different issue, and one we're not aware of. What browser/OS? Are you using an adblocker or Ghostery?

Avatar image for bradius
#5 Edited by bradius (109 posts) -

Browser: Chrome - Version 51.0.2683.0.

Operating System: Windows 10

Avatar image for bradius
#7 Posted by bradius (109 posts) -

Avatar image for angerawr
#8 Posted by angerawr (165 posts) -

@bradius: Can you send us the url for the video you're trying to watch?

Thanks!

Avatar image for phil456
#9 Posted by phil456 (30 posts) -

Been a long time since I last visited this site, so here are a couple of videos I would like to see again:

https://www.gamespot.com/reviews/ape-escape-2-review/1900-6030914/

https://www.gamespot.com/videos/spyro-a-heros-tail-official-trailer/2300-6098438/

Avatar image for brian_rowley
#11 Edited by Brian_Rowley (2 posts) -
Loading Video...

Video not working

Avatar image for tdmonkey
#12 Posted by TDMonkey (3 posts) -

try another browser

Avatar image for brian_rowley
#13 Posted by Brian_Rowley (2 posts) -

@tdmonkey: Edge, Firefox. Does not work. Probably just a very old video.