For everyone getting low FPS on PC with ATI Cards

#1 Posted by Pecone_Penev (267 posts) -

I am running the game on Ultra settings on 1680x1050 with no issues.

What fixed the framerate for me was to go under 3D Application Settings under Gaming in ATI Catalyst Settings and remove the checkmark on Use Application Settings under Smoothvision HD:Anti-Aliasing, leave the level at 2X and do not enable Morphological Filtering. Under game settings disable Vsync and adjust the Buffer Frames to 1. I am running the game on Ultra settings, only shadows on Very High with steady framerate and no issues.

I am running the game smooth as a butter on AMD Phenom II 955, 8GB DDR3, ATI Radeon HD 6870 1GB GDDR5, Win7 Ultimate 64bit.

I hope this helps. ;)

#2 Posted by caseystryker (5412 posts) -

That, and also the games shoddy post process fx and terrible SSAO drag the performance way down. I disabled them both by editing the gamerprofile, bumped the rest of the graphics up to high, very high and ultra and it looks better than it did with them enabled. At 1920x1080 I'm getting at steady 44-55 FPS with a crappy HD5830.

#3 Posted by AlmightyJim (25 posts) -
I can't find smoothvision HD.Using an HD6950 and 12.11 BETA drivers.
#4 Posted by caseystryker (5412 posts) -

In your CCC, it should be under Gaming, then 3D application settings.

#5 Posted by AlmightyJim (25 posts) -
Well,that's where I'm looking at right now.No smoothvision HD menu.
#6 Posted by Pecone_Penev (267 posts) -

Okay, so on the new beta driver it is just called Anti-Aliasing. Here is a screenshot: 


Just make sure that the Use Application Settings option isn't checked ;)

#7 Posted by AlmightyJim (25 posts) -
Oh,thanks a lot!BTW where did you get that wallpaper from?
#9 Posted by Pecone_Penev (267 posts) -

Oh,thanks a lot!BTW where did you get that wallpaper from?AlmightyJim


No problem. There you go:

and here are some more:D

#10 Posted by AlmightyJim (25 posts) -

Thanks again :):)

#11 Posted by Pecone_Penev (267 posts) -

Anytime, glad I can help :cool: