Epic Mickey 2 Questions and Answers - Shortness Theory, CONCLUSIVE EVIDENCE

  • 68 results
  • 1
  • 2
Avatar image for berethor099
#51 Posted by berethor099 (37 posts) -

Do you guys really think it was all Spector's fault?  It seems like to me that Disney (they publisher) forced Spector and Junction point to finsish the game earlier.  Sure, Warren may have lied along the way but I feel like it's Disney's fault for not allowing more time for the game to be developed properly.  

 

My biggest beef with spector is that he didn't stand up for himself.  It seems like he had this great "vision" for the game.  Then when Disney came along and cut down production Warren just scrambled to make the game somewhat (using that term loosely) coherent.  

 

If I was Spector, now that he's been axed.  I would be coming out publicly and stating that Disney basically screwed fans and the game over by cutting the dev time.  

Avatar image for katydiddd
#52 Posted by katydiddd (332 posts) -

Spector sold Junction Point to Disney, and then slacked off as manager.  Spector was the negligent "contractor", who was supposed to have the product on store shelves in September.  And, even when they gave him over 800 employees, in both the US and the UK, and an extension until November 18, it still stunk.

Because of Spector, Disney video games was bleeding money.  They could not miss the Holiday sales.

Spector was negligent in not paying attention -- in even watching the game for 5 minutes.

Spector's misrepresentations and false advertising left Disney open to a class-action lawsuit.  True, the compensatory damages to each purchaser may only be nominal -- like $10 each, and the payment to the lawyers may be like it the DELL  tax withholding settlement of 15 million.  THE  PUNITIVE  DAMAGES  that a Jury would award would be in the millions, because of the repeated, knowingly-false representations!!!

And, Warren Spector was making these false representations as an Agent of Disney, laying the culpability at Disney's doorstep.

Look at the newbies who have the impression that a single player can play as Oswald!

Mcbasilrocks thoroughly researched and itemized the flaws, which appear in Google Searches, for all the world to see. 

It was Spector who knowingly did the false interviews and sales pitches -- and who left Disney no choice but to shut down Junction Point, before it hit the fan in the legal arena.

Avatar image for katydiddd
#53 Posted by katydiddd (332 posts) -

Berethor wrote, "It seems like he had this great "vision" for the game."

Actually, Warren Spector had a completely different story line, and spent a lot of Disney's money on Concept Art and programming and animation -- so parts of it could even be played.  Mcbasilrocks researched them and posted links.

Then, Warrren Spector changed his mind, and fumbled around, without a clear story.

800 people would work, and work -- only to have it scrapped, and then scrapped again. 

You have read the email from a previous employee. 

Contact with former Junction Point employee - GameSpot.com

It was time to have a finished product, and Spector still didn't have a story!

He was like a building contractor, nailing boards without a floor plan -- and pipes that lead to nowhere.

Avatar image for wildhoney66
#54 Posted by wildhoney66 (297 posts) -

as grateful as i am that you are posting that and i am, i just don't have it on the Wii yet. i have the PS3 version and i'd love to see a version of it that's single player for that. and unless i missed it nobody's posted one of those yet. unless someone posted it somewhere else other than you tube. please by all means help a guy out. 

Avatar image for Painette
#56 Posted by Painette (25 posts) -
Mcbasilrocks, I read and opened every link you posted, and I really do commend you! Epic Mickey 2 was awful and lacked any depth whatsoever, and I don't know whether to be sad or happy that I will never be able to play a Junction Point EM3. BUT My epilogue was different.. it says "Use the wind drafts to glide across the ravine" and I have had it change once to 'Using the turnstiles', but then back to the one about the ravine? Any ideas? I thought this had something to do with the water/river underground Mean street where you have to use the helicopter move to get across, but to no prevail.. when I went beneath the fountain in OsTown, it changed to the epilogue about the turnstiles ONCE, however, when I left underground of the fountain it changed back. weird. Anyways, this game lacks throughout, the first one way completely better, and should have worked harder on it instead of rushing the release to get more money, which ironically, they didn't. Thanks!
Avatar image for berethor099
#57 Posted by berethor099 (37 posts) -
Well, that's too bad that Spector had to screw everything up. Even when I play this game I see the potential it had. It's a shame on guy can cause that much damage.
Avatar image for katydiddd
#58 Posted by katydiddd (332 posts) -

It was great hearing from Painette and berethor -- I agree with both of you.

I can't imagine why the Epilogue would say, "Use the wind drafts to glide across the ravine".  What system are you using?  (PS3 and XBox were programmed in the UK, while the Nintendo Wii was programmed in the USA.  Perhaps, Mcbasilrocks knows or will find out about "wind drafts" that sound like they are going to blow us to the island off where Seth is standing, down behind the Mean Street Train Station. 

I wonder what else they cut off the short game that they call "EPIC".

I only remember two wind drafts -- the first Underground and in Floatyard.  Neither of them are areas where more would be added.

Thinking abut the "potential" deeply saddens me (I wrote something else, but wouldn't print it.)

Avatar image for Painette
#59 Posted by Painette (25 posts) -
Well, I have a wii. And like I said before, when the epilogue changed to the one about the turnstile, it only did that under OsTown, and It said to open the way forward. This might be a longshot, but I think we were supposed to open the gate to Mickeyjunk Mountain from the turnstile, maybe? I don't know. But I think you may be right about going to the land behind Seth, It looks accessible as does the land in the distance from Autotopia. I cannot think of another Ravine in the course of the gameplay.. The game must have really been cut short... The whole game was really choppy and didn't make much sense, I thought it would make sense in the end, but in the ending where all the Pete's go through the projector, it left you with a cliff hanger. I was unable to find them where they would regularly be or anywhere else. This game was just ridiculous..
Avatar image for Painette
#60 Posted by Painette (25 posts) -
I also found it irritating that you could finish the game without completing side quests. You could ignore them completely. In EM1 The side quests added depth the the game, but in EM2 they are pointless.. I also do not like the quick save on the wii, because if you mess up once, you are screwed the rest of the game until you restart. Nonesense..
Avatar image for katydiddd
#61 Posted by katydiddd (332 posts) -

What Painette said about the shortness and choppiness of the game was confirmed by Mcbasilrocks' contact with an employee:

Contact with former Junction Point employee - GameSpot.com

http://www.gamespot.com/disney-epic-mickey-2-the-power-of-two/forum/contact-with-former-junction-point-employee-29351371/

- - - - -

SAVING  ON  A  WII:

My game had so many glitches and freezes, Oswald did unwanted activities, and I made so many errors, that I started saving games.  That way I have a place to revert to.  And, if I want to play part of the game again, I have a way to plug it in, and remove it.  I try to save every hour, and before big events.

In order to save, I moved Mickey a couple steps after the game indicated it saved, I would go into the pause menu and press "C" to quit.  (The game's save symbol lies -- especially in the Mad Doctor's Old Attic.  It indicates it saved right after you enter from the projector screen.  But, stopping the game there reverts you back to the beginning of the previous cartoon.  It does not really save until you jump the first boards.)

Then, I would go into my Wii Management Save files, on the lower left corner of the screen.

I put an SD CARD  in the slot, went to the  SD  TAB, and made sure that any Epic Mickey 2 games were erased.

Then, I went to the WII  CONSOLE  TAB, and selected  COPY  to copy that file to the  SD  CARD.

Then I selected Back and Back and Back -- to the  WII   MENU.

Then, I removed the  SD  CARD  from the Wii Console, and put it in my computer.

I pressed  "Windows symbol + E" to bring up a list of what was in my computer. 

I selected my  SD  Card, and private and wii and title and who knows what until I got a list of 4-letter FOLDER  names.  

I dragged  SERE  to my desktop, and named it  "SERE  001  where I am"

Then I put the SD  Card back in the Wii console and restarted the Epic Mickey 2 game.

- - - - -

It is a real pain, until the console freezes, or you get an automatically-saved Death Scene that keeps repeating -- even if you quit and restart the game.  Or, you were in a habit of clicking  "A" to get through lengthy conversations, and ended up agreeing to something bad that ruined the whole game. 

Sometimes, it is simple, like wanting to see what will happen if you give a gremlin a wooden gear and want to see "something really funny" that they promise you.  Then, you want to revert to what you have saved on the card.  (Erase the saved file on the Wii Saved Management Tab, and go the the SD  CARD tab and tell it to copy what is on the card onto the Wii System.)

Once, going through Blot Alley, I flipped guardians to befriend the Spatters, like I did in EM1 and Disney Gulch.  At the end, I didn't get the Superstar Award.  So, I reverted to a saved game, and did it again, using Watches, TVs, and PAINT.

Avatar image for berethor099
#62 Posted by berethor099 (37 posts) -

I also found it irritating that you could finish the game without completing side quests. You could ignore them completely. In EM1 The side quests added depth the the game, but in EM2 they are pointless.. I also do not like the quick save on the wii, because if you mess up once, you are screwed the rest of the game until you restart. Nonesense..Painette

Yeah, I wasn't a big fan of the side missions in this game either. I really disliked the "pick one or the other" type side missions. For example choosing to give items to Laurlie in the Museum or give them to the gremlin in the observatory. I know Epic Mickey is supposed to be about choice,, but they didn't design it well. I got the side mission from Lauralie and had NO idea that the same mission was tied to the observatory. No indication whatsoever.

 

It wasn't until I gave her the first item and looked at my menu screen that I noticed this side mission was also tied to the observatory. I started giving the items to the gremlin and in the end didn't recieve a pin. Why? Well I gave 9 (i think) to the gremlin and 1 to Lauralie. Apparently you have to give all 10 (or however many there where) to the same person. Just lame.

Same thing happened with the Bunny Children. The ice cream guy asked me to help him but once again I had NO idea that Ortensia wanted the bunny children for herself.

 

Yeah the game is super glitchy. I was in Blot Alley taking pictures for Encylopedia Wastlandica and died after taking two of the pictures. Don't really know what happend but the game glitched. It registered as taking the 1st picture before I died. So i could never "re take" or "re-register" the picture. When I respawed it said I had 2/3 pics. I never could take the picture, so I missed out on another pin.

Avatar image for Painette
#63 Posted by Painette (25 posts) -
Oswald CONSTANTLY would ruin my game play, often times I would have to play as Oswald AND mickey on 2 separate controllers to get the job done or get to a certain place. YES berethor! The side quests did that to me also! I gave my bunny children to the Ice cream guy once unknowingly! I did not think Ortensia wanted them until afterwards. But I did give a couple items to Lauralie, but had to buy them back for more than she bought them from me in order to give them to the observatory gremlin afterwards. Too bad I couldn't buy back the bunny children. I also hated the Venturland quest where you have to choose who to give the pearl to. I apparently also screwed up a Smee quest unknowingly and it said he fled and I couldn't open the door to Tortuga. Even If I DID open the door to Tortooga would I have been able to go there? I would replay the game, but I do not want to, even though it would only take an hour and a half of my time..
Avatar image for katydiddd
#64 Posted by katydiddd (332 posts) -

You two are really getting knowledgeable about the game!  You bring up things that I hadn't known or thought about.  I do have a couple experiences to share.

1)  You don't go to Tortooga.  You simply go through a door under the entry stream, and get a map of Tortooga, so the pirates can get their homeland back.

That seemed like a more noble thing to do than a stupid pirate in love, who wants to be Captain just to impress someone.  Then, he just sits around the cabin.

2)  OSWALD  AND  THE  SECOND  CONTROLLER:  The only way I could get to Alice's Balcony was to turn on a second controller, and  MOVE  OSWALD  OUT  OF  THE  WAY, and then leave him alone.

Otherwise, I would bounce on him when I came out of the Disappearing Ink; or he would bounce on me when he followed me out of the ink; or he would materialize in front of me on the Bird-Head Croquet Mallet.

3)  BUYING  BACK  THE  DEED  FROM  THE  MUSEUM:  In selling the 20 items to the Museum, I sold the Deed to the Bog Easy Old Town repaired building.  Then, I bought it back and experimented with both Metourie and Bertrand.

Previously, I had been able to complete it.

This way, I could get Bertrand into his shop and playing games -- but I could never get credit for it.  I could also complete Metourie's pictures and she would give me a pin -- but it would never be marked on my "Deed Quest".

Also, knowing that I had to do telephone boxes and magic hats, I did them while playing the game.  Only to have them not count.  If you spin  ALL  the magic hats before entering Bertrand's Magic Shop, you can never play the game.  Likewise, if you paint all the telephone boxes before given the quest, the only way to get credit for that quest is to do it the other way, and make a deal with the Mean Street Cinema.

The makers of the game are intentionally  mean-spirited, because it took extra work to do that extra programming.

Avatar image for Painette
#65 Posted by Painette (25 posts) -
I actually don't think I had those problems with the telephone boxes and Magic hats. But that reminds me, the Train Station in Bog Easy was glitchy for me and wouldn't unlock, it said I brought power to it, but then never worked..
Avatar image for hv37
#67 Edited by hv37 (25 posts) -

I'm going crazy trying to figure out how to access all the other lands. Is this possible or does it end with ventureland and bog easy?!?!?!?

Avatar image for wildhoney66
#68 Posted by wildhoney66 (297 posts) -

maybe you tube will help? if no one on here does, i haven't played the game in awhile so i can't think of how to help ya at the moment. also you always can do what i did is buy a strategy guide :)