Damn glitch...anyone else have this problem?

Avatar image for Fatal-Chaos


Forum Posts


Wiki Points



Reviews: 53

User Lists: 0

#1 Fatal-Chaos
Member since 2008 • 496 Posts

So i have Dishonored on PS3, so far i like it, bit of fun. But it just got me really annoyed, so starters i play this game slow, like i try to take enemies out quietly and i try to find all loot etc. So basically i spend like 3hrs in a mission. Well i noticed i tried to save my game and there was a line through "save game". I thought maybe i just couldn't save at this time, anyway i played on, still the same thing, i also noticed that the game wasn't autosaving. I played for about 2hrs collecting nearly every loot in the mission, when it was time for the next mission, as soon as the mission started my screen was black, so i committed suicide (happened to land in some water). Once choosing to load from previous save file, it took me all the fkn way back to when i just came out of the Overseer's Officer! All that time wasted, bloody frustrating...anyone get anything like this?