Mediterranean Defense not working

Avatar image for TharosTheDragon
#1 Posted by TharosTheDragon (25 posts) -
I'm playing Revelations on the 360. I'm at the part where it introduces you to Mediterranean Defense, I think Memory 3 in Sequence 3. I press any button at the pigeon coop to enter the Mediterranean Defense menu. I access the Little Prince mission which is the only mission available. It won't let me start it. I try to select my only assassin but he looks like he can't be selected. He's grayed out. It says to select a level 11 assassin and he's only level 10. But it gets worse. Not only can I not exit the menu by starting the mission, I can't exit the menu by backing out of it. I have to reset the game every time I access the pigeon coop. Is there any way to increase his level? I've been running around making him attack guards to give him experience but I don't know if that's doing anything. I can't tell how much experience he has. In the Mediterranean Defense menu there's some kind of experience bar but I don't know what it means. It's a full red bar. Does that mean he has no experience? Does it mean his experience is full but he can't level up for some reason? To the right of the bar it says 3800xp and below the bar it says 4710xp. What do those numbers indicate? How much experience he has? How much he needs? How much he'll get from the mission? It says the mission is worth 13500xp though. When I first gained the ability to call an assassin, I made sure the assassin died. Could that have anything to do with it? Then when I started the story mission where you train the assassin or something, there was a new assassin there. After the mission, I tried to get him to die as well. When his health finally drained all the way, it just said he was injured and would be ready again in 20 minutes. I waited for him to recover, but the Mediterranean Defense mission still won't work. I've tried restarting the mission, but that hasn't helped. I've tried returning to animus island and that hasn't helped either. I can't abort the mission, so I can't use tunnels. Can anyone answer any of my questions? Does anyone know anything I can try in order to fix this?