Problem With Attacked Convoy (Please Help)

Avatar image for lunarkilla
#1 Posted by lunarkilla (25 posts) -

maybe someone can help me with an issue i'm having that's been going on for a few days now. so i have 3 land convoys i send all 3 with iventory, 2 of them make it back and the 3rd didn't. the game never made me aware that the convoy was under attack. i have always successfully defended my convoy whenever needed becasue i would get the message telling me to defend my convoy, but for whatever reason i didn't get or see it this time. it wasn't until i tried to send my convoys again that i noticed one was out of commision. the other 2 were empty and available, and the other shows the inventory i sent it with and is worth 3696 and has a RED 'X' and says ATTACKED. I tried looking in all locations to see if i could still defend the convoy but there was never any luck as it never shows it needing to be defended. so i figured it was destroyed so i tried to craft a new one. that doesn't work either because although i have the materials to do so it keeps saying my INVENTORY IS FULL. therefor i still have 2 convoys i can use and the 3rd one is just taking up space. i also tried to see if i could delete the attacked convoy in my trading section but there isn't any option what so ever when its highlighted. pressing any buttons on it while its highlighted does nothing. i've even tried going to different stores and the homesstead to try and see if i get a different option, but i still have the same issue. i've tried looking up this issue online but everyone keeps saying craft a new convoy which clearly isn't the answer for me. so i'm making it clear on my post that, that DOESN'T WORK. so please don't suggest that to me. i don't know if i have a glitch or bug and maybe this isn't suppose to happen. does anyone else have this same issue or know what i'm talking about? before anyone asks. i have Assassin's Creed 3 on xbox 360 if that matters. also i still send the other 2 land convoys and don't have any issues. i also noticed my convoys never get attacked anymore after having this issue with the other one. i've always sent my convoys with a 10% risk to the same merchant per convoy. the one that i'm having an issue with should have had a 10% risk as well. i think it was sent to ELIZABTH MURRAY'S FINERIES in BOSTON at the time. thank you guys in advance for your help.

Avatar image for TheEroica
#2 Posted by TheEroica (17324 posts) -

Not really sure about this one... sounds like a glitch to me.  im asuming that if the convoy was under attack it would be in the frontier right?  weird that nothing is showing up.

Avatar image for Pihve
#3 Posted by Pihve (25 posts) -
I have the Same problum on PS3, red x, only diffrence is I am on PS3 and the dollar amount is 3536. Going to the same shop, I hope they address this soon. Help anyone.
Avatar image for crwnedprince
#4 Posted by crwnedprince (550 posts) -
at least you have convoys ever since the training mission it said i failed and i havent figured out how to send convoys since