Loading save causes ctd help!

#1 Posted by banjotooie22 (14 posts) -

hi i have recently bought elder scrolls 4 goty and been having a blast. but today when i tried to load my save it shows the loading screen for just a second and then it crashes to desktop while the games music is playing in the background then a error screen pops up on the desktop screen saying the oblivion has suffered a serious error and had to be shut down. i tried other saves and they don't work ether the only saves that work are the ones before or during the hackdirt quest any saves after it crash. I'm only at day 16 and at level 5. i need help as i cant keep playing if  i am not able to save.

the error signature says: app-name oblivion.exe    app-version  mod-name oblivion.exe

modver offset 0028e53f


my computer is a windows xp hp pavilion a810n with a agp his radeon hd4670 iceq.


also three notes 

note 1 is im typing this on my dads computer as the one with oblivion installed dose not have Internet.

note 2 is just before this problem started i ignored a pop up from hp for searching to update drivers as it may require Internet.

note3 i did indeed install knights of nine and shivering isle.


please help me fix this game.