how to run nfs nost wanted 2012 on 1920x1080 res on pc

#1 Posted by sam199 (2 posts) -

 

hi all, i just bought this game. whenever i launch it, it starts in a windowed mode and also in graphic settings it show max res available is 1280 x 720, when i press alt+enter, game becomes fullscreen but the res is still the same, its very frustrating to play it in windowed mode

i hav a 1080p monitor and would like to run the game on 1920x1080 res

 

 my pc config is amd opteron 1354 2.2ghz quad core

                      4 gb ddr2 ram

                      sapphire ati radeon 6870 hd (1 gb)

                      and a well 1080p monitor :)

 

 

 also i got nfs hot pursuit 2010 it runs perfectly on 1920x1080

i searched the origin client for settings but did not find any

any help appreciated thanks

 

 

 

 

 

 

 

 

 

 

#2 Posted by Frag_Maniac (2059 posts) -

Go to Documents\Criterion Games\Need For Speed(TM) Most Wanted and open the config.NFS13Save file with Notepad. Scroll down to where it says Width=, Height=, and set them to 1920 and 1080.

On windowed mode, there is no windowed vs fullscreen option in the menu, but there does seem to be a visible window frame upon exiting the game. It shouldn't show in game though, at least it doesn't for me.

That same config file I mentioned has a "ScreenScale" command, and by default it's set to 0, which as far as I can tell means windowed mode. I tried setting it to 1 though and I didn't see the window frame when exiting, but the game seems to play a bit smoother with it on 0.

I also set LockTo30 to true in that config file, which locks the FPS to 30. I have a 7970 and use max settings at 1080p, and for the most part get a solid 60 FPS, but there are places where the game starts fluctuating anywhere from 35 - 55 FPS, and then it looks choppy.

It's not the amount of FPS, but the fluctuation that causes the choppiness. Some might think 30 is too low FPS to have to play at, but there's no lag and without the fluctuation, no choppiness either.

This is not just me, I've heard people with GTX 680s and other high end cards using LockTo30 to remove choppiness too. On my GTS 250 the chop was so bad I got a yo yoing effect with accceleration and steering, but with LockTo30, even my GTS could play it pretty well, but of course not with max settings.

#3 Posted by sam199 (2 posts) -

hey man thanks for all ur help

now the game does run on 1080p but framed, when i alt+ enter it goes back to 720p and graphics setting changes to 800 x 600, screen scale=1 did remove the frame but sometimes lags happen

how can EA/Criterion make such a blunder theres no option for a higher graphical setting in in-game settings menu

how can i get 1920 x 1080 option in in-game graphic settings menu

also am i the only one having this problem or u also hav highest possible setting of 1280 x 720 in in-game settings menu

wrote to EA but still no reply

thanks again for taking the trouble to find a solution

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

#4 Posted by SLOPPY1001 (20 posts) -
Hi, just as a shot in the dark, have you tried to right click on your Need For Speed desktop icon and from the SHORTCUT TAB there are options in the RUN section, have a play with them. Also you could go into your video card control center and have a look for some settings like GPU scaling, you shouldn't have to but it's worth a try.
#5 Posted by MilardRi77 (12 posts) -
https://www.youtube.com/watch?v=IOYUMThyMXE