Choppy fps/stuttering? (Oc'd gtx580/2600).

#1 Posted by Stiler (357 posts) -

Anyone else getting this? It seems the game runs at 60fps, but if it even dips into the 50's things get "Stuttery."


At first I thought it was a vsync issue, but I can't seem to even find vsync in the graphical options.

Also is there no official EA forum for this game? Seems weird that EA has forums for Battlefield, Burnout, MoH, etc but not any Need For speed forum....

#2 Posted by SSS1989 (45 posts) -

Yeah, I had that too when it stutters. The game takes alot of resources, so I prefer it myself to tone down the shadows and turn off the high resolution textures. I have it with the AMD Radeon HD 7700 series recently.

#3 Posted by Zipper761882 (588 posts) -
I'm running a single 6950 2gb, 8gb ram, and an AMD-4170 quad core 4.2 ghz. Pretty much a budget rig. I can max the game at 1920x1080 but it gets stutery sometimes with alot going on. The odd thing is, I ran FRAPS to check the framerate and it is showing that it is staying around 40ish even when the stuttering is happening. Maybe it is less a framerate issue and more something to do with the game itself? The thing is is, if I lower Ambient occlusion and Geometry Detail to medium(what they were set to by default) the problem becomes much less apparent, yet the rise in framerate is only maybe 5-10 fps and often even less than that. I tried turning off High Resolution Textures and it literally made NO difference whatsoever in either framerate or the stuttery issue. Who knows. The game is still plenty playable though. I went in expecting a Burnout clone and thats what I got so I am happy with the game unlike some.
#4 Posted by joshphillips (2962 posts) -
Found turning the lighting to medium helps a lot. You lose the wet road look when it rains, but it helped my fps dramatically. Also make sure you have vsync forced in your control panel. 4g ram 550ti 1g Q6600 2.4
#6 Posted by zzzronin (7 posts) -

I have an I5-750 with Geforce 570GTX, the game is playable at 1920x1080 with everything on, but framerate constantly drop at somes place so the car seems to slow down a bit sometimes and make things harder to be played.

It must have a patch to correct this.  Graphics are great, but now enough to be so heavy.  For now, I drop the resolution to 1280x720 (yes like the Xbox :?) so the game is now much more enjoyable to play.

Give it a try !

#7 Posted by qqxLV (111 posts) -

I got a laptop with Intel core i5, 4GB DDR3, HD7670M which runs Max Payne 3 on medium/high in a pretty smooth frame rate. BUT this thing, jesus almighty baby christ, it's barely playable. Altough I can already tell that the game is a horrible result of what I've expected it to be, I kinda still want to try it, but it's impossible with the huge amount of resources it requires and the stuttering.

#8 Posted by shoaibasghar_s (1 posts) -

getting 10-15 frames at high settings and 20-30 at low settings resolution is 1280 x 1024 at both.
afterburner shows gpu max usage during game time was 75 percent....
i mean shouldn't it use gpu 100 % and give better frames? or is it game issue?


Specs: win 7 32 bit
core i3 first gen
2 gb ram
5770 1 gb card

#9 Posted by anialater (11 posts) -
I have the same problem. I have a decent PC (2500K @ 4.5Ghz, 12Gb Ram and a 660Ti) however the FPS drops from the frame limited 60FPS all the way down to around 30ish which makes driving very hard (as you can feel the frame drop and I often loose control of the vehicle at high speed). I enabled MSI Afterburner in game and the GPU usage is never at a 100% even during the frame drops which makes no sense. Normally if your card is not powerful enough the GPU usage will reflect 100% and the frames will drop (i.e. no matter how hard your card tries it cannot run the game at high/stable frames). This is not happening to me which leads me to believe there is something else going on. I changed all the settings down to low, now the GPU usage has dropped to around 35-40% and the frame drops seemed to have stopped (i.e. FPS seems stable at a constant 60). With everything on it's highest setting GPU usage was only at around 65-70% but the frame rate would drop. Odd. It must be one of the settings that are bugged. I am running the latest Nvidia BETA drivers (310.33) on Windows 8 x64.
#10 Posted by Mathesar (571 posts) -

My problem is the same as what OP described, anything below 60fps causes a jittery stutter in the framerate, tried lowering settings and it only helps a little. i7 920 @ 3.6ghz / GTX 480

#11 Posted by blastmaster2k2 (382 posts) -

Yea, it's not optimized well. I get a stuttering like effect from time to time in the game as well. Maybe they'll put a patch out for it but I wouldn't hold my breath. They didn't support Hop Pursuit for anything.

#12 Posted by Addict187 (626 posts) -
Turn the geomatry setting to low and light to med. The game runs butter smooth for me on my GTX 670 after changing the tow settings
#13 Posted by Frag_Maniac (2059 posts) -

First, you need to specify exactly what you mean by stuttering. When I described mine as a yo yoing forward motion and steering, I got more than one response from players saying they had exactly the same.

This problem can be solved by editing the config file on the PC version to set LockTo30 to true vs the default false. The tradeoff is you'll be capped at 30 FPS as per NFS The Run was, but at least it's smooth gameplay.

This file to edit is callled config.NFS13Save, and is located at Documents\Criterion Games\Need For Speed(TM) Most Wanted. You can open and edit it with Notepad, and the LockTo30 command is the second one listed in the file.

Basically it looks like we have to settle for console quality in may ways in the latest NFS PC titles, including frame rates.

#14 Posted by Frag_Maniac (2059 posts) -

Forgot to add that this indicates that it's not so much the frame rate level you're getting as the fluctuation of frame rate that's the problem. So try what I said, even if you're skeptical that an FPS as low as 30 might make it worse. What it does it keep it at a solid frame rate with no fluctuation, and in turn smooths out the texture streaming immensely.