Titanfall,Xbox One issue.

#1 Posted by brimmul777 (1059 posts) -

A quick question for anyone else.I am having lagging issues with Titanfall,both on multiplayer and on multiplayer campaign.Am I the only one getting this.Please answer if you have any issues with Titanfall {Xbox One}.Thank You.

#2 Posted by thenephariouson (3952 posts) -

I still play Titanfall frequently both in Party mode and on my own, being in the UK I usually get a server connection time of between 28Ms and 32Ms to the 'Western Europe' servers, my UK friends receive around the same times.

I have never yet experienced and connection issues Lag or otherwise.

#3 Edited by Venom951 (365 posts) -

Never had lag in the game .

#4 Edited by adders99 (2564 posts) -

I have experienced it with the bots skipping through map... that was a while ago and have not experienced it for a while now. I am playing on the Australian servers normally get around 45 50 ping.

#5 Posted by BattleSpectre (5952 posts) -

@adders99 said:

I have experienced it with the bots skipping through map... that was a while ago and have not experienced it for a while now. I am playing on the Australian servers normally get around 45 50 ping.

Same here, those bots skipping through the map got me paranoid thinking I may be lagging myself lol. I haven't played Titanfall recently but @brimmul777 sounds normal to me. You might just be having a bad connection, everyone in here would be lying if they say they've never lagged in an online game.

#6 Edited by sailor232 (4273 posts) -

I have had a lagging problem twice, like the game played like a slide show, impossible. I checked my ping and it was normal at 50. I don't have a clue why that happened but like I wrote, it only happened twice to me, not a big deal in the end.

#7 Posted by a55a55inx (4124 posts) -

I've seen people skipping frames when they have a bad connection. And I did experience framerate drops (to 1-2fps) at certain times...but I would guess that it happens less than 5% of the time I play.

#8 Edited by DaBrainz (7604 posts) -

I have had problems since the matchmaking update. All of the other good players must live further away.

#9 Posted by madskills6117 (4021 posts) -

The game has had major lag for me the last two days. Yesterday it was off and on but today it's a complete mess. Hopefully it's ironed out soon.