BFBC2 servers laggy?

This topic is locked from further discussion.

#1 Posted by Da_lil_PimP (4242 posts) -

I just got on and played some BC2 and the games I've been put in have both been quite laggy. It just started happening today so I wonder is anybody else having this issue or just me?

#2 Posted by Drakshadow97 (201 posts) -

I just got on and played some BC2 and the games I've been put in have both been quite laggy. It just started happening today so I wonder is anybody else having this issue or just me?

Da_lil_PimP

Not me are you sure it's not your connection?

#3 Posted by Da_lil_PimP (4242 posts) -

[QUOTE="Da_lil_PimP"]

I just got on and played some BC2 and the games I've been put in have both been quite laggy. It just started happening today so I wonder is anybody else having this issue or just me?

Drakshadow97

Not me are you sure it's not your connection?

It could as I haven't tried a different game. I thought that they were still having server issues and as a result I was getting lag. Although I was on my PS3 just fine, and I have that wireless and my 360 wired. I'll probably just try again later. Maybe it was just the games.
#4 Posted by Drakshadow97 (201 posts) -

[QUOTE="Drakshadow97"]

[QUOTE="Da_lil_PimP"]

I just got on and played some BC2 and the games I've been put in have both been quite laggy. It just started happening today so I wonder is anybody else having this issue or just me?

Da_lil_PimP

Not me are you sure it's not your connection?

It could as I haven't tried a different game. I thought that they were still having server issues and as a result I was getting lag. Although I was on my PS3 just fine, and I have that wireless and my 360 wired. I'll probably just try again later. Maybe it was just the games.

Just saying I haven't had any lag issues but it can be your NAT or netwrok connection.

#5 Posted by Da_lil_PimP (4242 posts) -

[QUOTE="Da_lil_PimP"][QUOTE="Drakshadow97"]

Not me are you sure it's not your connection?

Drakshadow97

It could as I haven't tried a different game. I thought that they were still having server issues and as a result I was getting lag. Although I was on my PS3 just fine, and I have that wireless and my 360 wired. I'll probably just try again later. Maybe it was just the games.

Just saying I haven't had any lag issues but it can be your NAT or netwrok connection.

Well MW2 says my NAT is open. It must have just been the games I got put into. I'm playing fine now.