No voice audio on Assassins Creed 3?

This topic is locked from further discussion.

#1 Posted by jakewidgeon (25 posts) -
I have been playing this game for about a week now, no hiccups. But all of the sudden there is no voice on cutaways or when talking to people. I have tried everything, changing audio settings.....resetting cache, trying other games (Call of duty audio works fine), resetting the tv and xbox, unplugging everything. There is every other noise still working (Walking, music, etc) but no voice. I can see what they are saying with subtitles, but this really puts a damper on the game. does anybody have a fix? Thanks!
#2 Posted by ChubbyGuy40 (26273 posts) -

I actually had this same issue when I rented it. No idea what causes it or how to fix it. Pretty sure it was because the disk was scratched though.

#3 Posted by Minishdriveby (10520 posts) -

The Assassin's Creed series alwas had these audio glitches in them. It's the one thing that has really bothered me throughout the series.

#4 Posted by jakewidgeon (25 posts) -
I checked the disk, which is brand new and hasnt left the system since i began playing it, and it has no scratches whatsoever.. I have tried even starting a new game, still no voice audio. Maybe I'll go back to gamestop and see if they will replace it.. just wasnt sure if anybody else had this problem with a fix?
#5 Posted by Daizengar (45 posts) -
There was a similar situation with another Ubisoft game, Ghost Recon: Future Soldier. Some say installing the game to your drive should fix it, others just reset their system and it works. Not sure if the same applies to AC3 yet, as I don't have it, but it's worth a shot. I think it has something to do with this new audio stuff they're using in their new games. In fact, starting up GR:FR requires you to update it so it can sorta install the new sound stuff. Still doesn't have better audio than Battlefield 3, but whatever works for Ubisoft. EDIT: typo.
#6 Posted by jakewidgeon (25 posts) -
what exactly do you mean by installng the game to your drive?
#7 Posted by Daizengar (45 posts) -
It's easy to do, takes a little time, but also takes up a good portion of storage space. You basically make sure the disc is in your Xbox, go to your dashboard, press X to go to your Game Details while hovering over the Play Game option, then choose install. Like I said before, it'll take up some memory, but it's supposed to help the game run faster and better. Now, this won't let you play the game without a disc, so don't get that idea, but it's still a fairly handy feature. http://support.xbox.com/en-US/xbox-360/audio-video-setup-and-use/install-play-delete-game
#8 Posted by jakewidgeon (25 posts) -
It keeps getting to about 30% and then stopping, with a message that says it cannot read disk. which is very weird since the disk has no scratches whatsoever.. but anyway thanks for the help!
#9 Posted by Daizengar (45 posts) -
In that case, I think it's a disc problem. I'd take it back to Gamestop, explain the situation, tell them how you tried to install it and it gave you that error.