Having trouble connecting to Xbox Live.

This topic is locked from further discussion.

#1 Posted by Steel-Panther (484 posts) -
I posted this on the Xbox forums and haven't gotten any replies yet so i just thought i'd ask here. First of all, i use an ethernet cable to connect. I recently fixed the cable because the end-piece was partially broken and now my 360 won't even recognize the cable. I tested the cable out on my computer and that works so the problem has to be with either my 360 or the router. I've had problems in the past where my 360 couldn't connect to the internet, and normally resetting the router would fix it, but for this it instantly pops up with an error while it's trying to connect to the network. Also, i haven't changed any of my router's settings. I'm using a Linksys WRT54GS ver. 6 router Any suggestions?
#2 Posted by Steel-Panther (484 posts) -
#3 Posted by Doomtime (4282 posts) -
Try a different Ethernet cord first
#4 Posted by Aravix (1282 posts) -

I'm not too good with routers, but I'll suggest something.

Go into your Router settings (should be, then go to the security tab and uncheck "Filter Internet NAT Redirection". (If it's checked, maybe uncheck it to see if that works?)

This is what my problem was once, maybe and hopefully it will solve yours.

Other than that maybe you could try to reset it through the button on the back. I imagine you've tried that though. :(

#5 Posted by Steel-Panther (484 posts) -
Thanks but i tried the NAT Filter thing and it didn't work. I tried using a different ethernet cord through the router and that didn't work either, BUT i did connect my 360 directly to the modem and that did work. So now i'm really confused. I'm guessing there's an issue between my 360 and the router but i have no idea what it is.
#6 Posted by Orgymang (314 posts) -

Have you tried inputing your information (IP, Subnet, Gateway, & DNS) manually or if already done manually, then set to automatic on your Xbox 360? How about moving the cable to a different port on your router? I, myself, have always had problems with Linksys routers for some reason. They would work fine for a week or so and then I would lose connection to the internet and the only way I could fix it was to reset the router to factory defaults and re-setup everything. So, you may wish to try that as a last resort.

#7 Posted by Steel-Panther (484 posts) -
Didn't work but thanks anyway. And yes, i too hate Linksys. I used to have a D-Link router which worked great but it wasn't wireless (needed one for my laptop).
#8 Posted by Steel-Panther (484 posts) -
1 more bump...