No Remote Play for EA UFC :(

#1 Posted by jonesy1911 (3482 posts) -

Just testing out the demo, which is really good imo. Thought to myself why not try out RP, turns out it doesn't let you fight; you have to watch the CPU..... Bad times.

#2 Edited by Blabadon (25949 posts) -

Wait, really? Damn, that sucks.

#3 Edited by santoron (7692 posts) -

I thought remote play was include at the system level for all non accessory based titles.

Hopefully this is a bug or a demo thing. Remote Play needs to be ubiquitous.

#4 Posted by edwardecl (2116 posts) -

How do you watch the CPU, do you have to take the Playstation apart?

#5 Edited by santoron (7692 posts) -

I'm on my phone atm so I can't link it, but I googled "UFC remote play" and there is a video from just a couple hours ago of a guy playing the demo through the vita...

#6 Posted by jonesy1911 (3482 posts) -

That's strange because I'm trying right now and i can only watch, let me try to see if it will let me use the ds4 while in RP

#7 Posted by jonesy1911 (3482 posts) -

Hmmm ignore the thread people game is now playing, first time i booted into remote play for the game it said no ds4 connected. Then I tried using the DS4 which kicks you out of RP. So i boot it up in RP one last time and it works now.

#8 Edited by AmazonTreeBoa (16745 posts) -

...

#9 Edited by ShepardCommandr (2417 posts) -

Why would you even want to play on a tiny screen with a horrible battery life?

#10 Posted by jonesy1911 (3482 posts) -

Why would you even want to play on a tiny screen with a horrible battery life?

Because I have kids and don't like playing violent games in front of them which means I can only play at certain times of the day without remote play...

#11 Edited by PS4hasNOgames (1387 posts) -

thanks for reminding me to download it.

#12 Posted by gregbmil (2607 posts) -

i think remote play kinda sucks anyways. It just makes it hard to play any PS4 game, imo.

#13 Posted by UnbiasedPoster (743 posts) -

It's just a demo...