PS3 No Longer Recognises my USB Stick

This topic is locked from further discussion.

#1 Posted by star1976 (3 posts) -
Hi. My PS3 will not recognise my USB stick that I have been using successfully for over a year. I have copied a .avi file there and when I go to videos normally I would see the usb and press triangle which would then show the files but its like it cannot see the stick. I have tried everything like reformatting again to fat32 and checking there are no partition etc. Anyone have any ideas? the controllers are charging fine from the same USB slot and the USB stick is working fine in 2 different laptops. Only thing i can think of is my daughter starting playing this wonderbook of spells game and the PS3 did an upgrade before she could play it. Could this be causing an issue? If so how do I revert back? thanks
#2 Posted by KiriharaZro (20 posts) -
You tried with another USB? if another do the same maybe its a software conflict in your PS3 since the controllers charges fine.
#3 Posted by star1976 (3 posts) -
I will give another USB a try tonight. Any idea how to resolve this potential software conflict?